1

I will write the order of when things started occurring.

When I started writing with LyX, I couldn't write in Hebrew, until someone sent me this package called culmus, which fixes the problem. The problem basically was not being able to preview what I was writing, so after installing this everything was OK for a while.

Then I added modules and added shortcuts (shortcuts from Hebrew to English and Theorem module). Then for some reason it stopped previewing my files again. So I changed the settings back to what they were before. It didn't work. I uninstalled and installed LyX and that Hebrew package a million times, and I still can't preview my things.

I will write what it is written in the log.

I just found out I can't upload notepad files, so I will just copy paste the log.. If there is a better way for me to present the problem, please let me know, I don't really understand how the program works. I have friends in the university that write with LyX in Hebrew and they don't have this problem, and they didn't know how to fix it unfortunately, so if someone here can help me fix this problem that would be awesome. Thanks!

enter image description here

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (MiKTeX 2.9) (preloaded format=pdflatex 2014.7.31)  31 JUL 2014 20:07 entering extended mode
**newfile1.tex

(C:\Users\DavidCiprut\AppData\Local\Temp\lyx_tmpdir.bMcmcnO18020\lyx_tmpbuf0\ne wfile1.tex LaTeX2e <2014/05/01> Babel <3.9k> and hyphenation patterns for 68 languages loaded.

("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\article.cls" Document Class: article 2007/10/19 v1.4h Standard LaTeX document class ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\size10.clo" File: size10.clo 2007/10/19 v1.4h Standard LaTeX file (size option) ) \c@part=\count79 \c@section=\count80 \c@subsection=\count81 \c@subsubsection=\count82 \c@paragraph=\count83 \c@subparagraph=\count84 \c@figure=\count85 \c@table=\count86 \abovecaptionskip=\skip41 \belowcaptionskip=\skip42 \bibindent=\dimen102 ) ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\base\fontenc.sty" Package: fontenc 2005/09/27 v1.99g Standard LaTeX package ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\base\t1enc.def" File: t1enc.def 2005/09/27 v1.99g Standard LaTeX file LaTeX Font Info:    Redeclaring font encoding T1 on input line 43. )) ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\base\inputenc.sty" Package: inputenc 2014/04/30 v1.2b Input encoding file \inpenc@prehook=\toks14 \inpenc@posthook=\toks15 ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\base\latin9.def" File: latin9.def 2014/04/30 v1.2b Input encoding file ) ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\babel-hebrew\cp1255.def" File: cp1255.def 2004/02/20 v1.1b Hebrew input encoding file )) ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\tools\theorem.sty" Package: theorem 1995/11/23 v2.2c Theorem extension package (FMi) \theorem@style=\toks16 \theorem@bodyfont=\toks17 \theorempreskipamount=\skip43 \theorempostskipamount=\skip44 ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\tools\thp.sty" File: thp.sty 1995/11/23 v2.2c Theorem extension package (FMi) )) \c@theorem=\count87 ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\babel\babel.sty" Package: babel 2014/03/24 3.9k The Babel package
*************************************
* Local config file bblopts.cfg used
* ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\00miktex\bblopts.cfg" File: bblopts.cfg 2006/07/31 v1.0 MiKTeX 'babel' configuration ) ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\babel-english\english.ldf" Language: english 2012/08/20 v3.3p English support from the babel system ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\babel\babel.def" File: babel.def 2014/03/24
3.9k Babel common definitions \babel@savecnt=\count88 \U@D=\dimen103 ) \l@canadian = a dialect from \language\l@american  \l@australian = a dialect from \language\l@british  \l@newzealand = a dialect from \language\l@british  ) ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\babel-hebrew\rlbabel.def" File: rlbabel.def 2005/03/30 v2.3h Right-to-Left support from the babel system  Hebrew language support from the babel system ) ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\babel-hebrew\hebrew.ldf" File: hebrew.ldf 2005/03/30 v2.3h Hebrew language definition from the babel sys tem Hebrew language support from the babel system

Package babel Warning: No hyphenation patterns were preloaded for (babel)                the language `Hebrew' into the format. (babel)  Please, configure your TeX system to add them and (babel)              rebuild the format. Now I will use the patterns (babel)                preloaded for english instead on input line 57.

\l@hebrew = a dialect from \language0 )) ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\babel-hebrew\lheenc.def" File: lheenc.def 2005/05/20 v1.2c 7-bit Hebrew font encoding (test version: sti ll liable to change) ) No file newfile1.aux. LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 29. LaTeX Font Info:    ... okay on input line 29. LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 29. LaTeX Font Info:    ... okay on input line 29. LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 29. LaTeX Font Info:    ... okay on input line 29. LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 29. LaTeX Font Info:    ... okay on input line 29. LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 29. LaTeX Font Info:  ... okay on input line 29. LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 29. LaTeX Font Info:    ... okay on input line
29. LaTeX Font Info:    Checking defaults for LHE/cmr/m/n on input line 29. LaTeX Font Info:    Try loading font information for LHE+cmr on input line 29. ("C:\Program Files (x86)\MiKTeX
2.9\tex\latex\babel-hebrew\lhecmr.fd" File: lhecmr.fd 2005/05/20 v1.2c Hebrew default font (test version: still liabl e to change) ) LaTeX Font Info:    ... okay on input line 29. ! Font LHE/cmr/m/n/10=jerus10 at 10.0pt not loadable: Metric (TFM) file not fou nd. <to be read again> 
                   relax  l.29 \begin{document}
                      I wasn't able to read the size data for this font, so I will ignore the font specification. [Wizards can fix TFM files using TFtoPL/PLtoTF.] You might try inserting a different font spec; e.g., type `I\font<same font id>=<substitute font name>'.

Missing character: There is no y in font nullfont! Missing character: There is no c in font nullfont! Missing character: There is no b in font nullfont! Missing character: There is no y in font nullfont! Missing character: There is no c in font nullfont! Missing character: There is no 1 in font nullfont! [1

] (C:\Users\DavidCiprut\AppData\Local\Temp\lyx_tmpdir.bMcmcnO18020\lyx_tmpbuf0\ne wfile1.aux) )  Here is how much of TeX's memory you used:  1194 strings out of 493706  14431 string characters out of 3142147  68928 words of memory out of 3000000  4552 multiletter control sequences out of 15000+200000  4403 words of font info for 15 fonts, out of 3000000 for 9000  1025 hyphenation exceptions out of 8191  25i,4n,23p,176b,122s stack positions out of 5000i,500n,10000p,200000b,50000s

Output written on newfile1.pdf (1 page, 870 bytes). PDF statistics:  6 PDF objects out of 1000 (max. 8388607)  0 named destinations out of 1000 (max. 500000)  1 words of extra memory for PDF output out of 10000 (max. 10000000)
  • Welcome to TeX.SX! The best way to ask a question on TeX.SX is to put together a minimal (non-)working example (MWE) that reproduces the exact problem. A log file can be helpful, but an MWE would be best, otherwise we'll just be guessing about certain things. If it's helpful, you can also take a look at LyX user questions on TeX stackexchange, which describes how to put together an MWE for LyX. – Adam Liter Jul 31 '14 at 17:39
  • 1
    Unpack the culmusXXX.zip package in some folder (outside your miktex). (Don't run the .bat-file). You should get a root folder with subfolders fonts, tex and some more. Check if in the folder miktex/config is a updmap.cfg. Open miktex setting and attach the root folder as a new root. In the command line run "updmap". Then hope the best (lyx may be easy to use put it is painful to debug). – Ulrike Fischer Jul 31 '14 at 17:46
  • Hey Adam, thank you for the response, I will read about what MWE is an create one as soon as possible. Ulrike Fischer, thanks for the response, I have found the folder udmap.cfg however I didn't understand the part "Open miktex setting and attach the root folder as a new root. In the command line run "updmap"" , where is miktex settings? and how do I do that? I would be happy if you can clarify that. Thanks for the responses guys! I really appreciate it – Charles Carmichael Jul 31 '14 at 18:30
  • Search in the windows start menu for miktex settings. There is tab "roots" where you can attach the main culmus folder. Google about how to open a command line. Enter there "updmap" and hit enter. – Ulrike Fischer Jul 31 '14 at 18:45
  • Hello @UlrikeFischer I have the same problem. I'm using Windows 8. Can you please elaborate on the steps? In particular, I have an *.exe culmus file and therefore can't unzip it etc. Many thx in advance! – Amihai Zivan Oct 7 '14 at 7:31
2

Try switching to XeTeX. Using XeTeX solves lot's of bugs when using Hebrew (like hyperref is actually working). It's relatively easy to set up LyX to use XeTeX for Hebrew documents.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.