4

I am trying to use this answer to get large quotation marks,

\PassOptionsToPackage{svgnames}{xcolor}
\documentclass{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{libertine} % or any other font package (or none)
\newcommand*\quotefont{\fontfamily{fxl}} % selects Libertine for quote font
\usepackage{tikz}
\usepackage{framed}
% Make commands for the quotes
\newcommand*{\openquote}{\tikz[remember picture,overlay,xshift=-15pt,yshift=-10pt]
 \node (OQ) {\quotefont\fontsize{60}{60}\selectfont``};\kern0pt}
\newcommand*{\closequote}{\tikz[remember picture,overlay,xshift=15pt,yshift=10pt]
 \node (CQ) {\quotefont\fontsize{60}{60}\selectfont''};}
% select a colour for the shading
\definecolor{shadecolor}{named}{Maroon}
% wrap everything in its own environment
\newenvironment{shadequote}%
{\begin{snugshade}\begin{quote}\openquote}
{\hfill\closequote\end{quote}\end{snugshade}}

%\usetheme{Darmstadt}
\usefonttheme[onlylarge]{structurebold}
\setbeamerfont*{frametitle}{size=\normalsize,series=\bfseries}
\setbeamertemplate{navigation symbols}{}

\setbeamercolor{background canvas}{bg=black}
\setbeamercolor{normal text}{fg=white}

\makeatletter

\makeatother

\begin{document}
\begin{frame}
\begin{shadequote}
A common mistake that people make when trying to design something completely
foolproof is to underestimate the ingenuity of complete fools.\par\emph{Douglas Adams}
\end{shadequote}
\end{frame}

\end{document}

Unfortunately this now gives me miserable and skinny quotation marks instead. I heard that the libertine package had changed recently but I can't see how to fix this. I am using TeX Live 2013.

The error I get is

LaTeX Font Warning: Font shape `T1/fxl/m/it' undefined
(Font)              using `T1/cmr/m/n' instead on input line 130.
7

Indeed, the font family name has changed. You can use

\newcommand*\quotefont{\fontfamily{LinuxLibertineT-TLF}} % selects Libertine for quote font

I suggest also to change \kern0pt into \kern4pt or something else that avoids the quote bumping in the first character.

Note that \RequirePackage is not needed: the option to xcolor can be passed in the \documentclass line.

\documentclass[xcolor=svgnames]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{libertine} % or any other font package (or none)
\newcommand*\quotefont{\fontfamily{LinuxLibertineT-TLF}} % selects Libertine for quote font
\usepackage{tikz}
\usepackage{framed}
% Make commands for the quotes
\newcommand*{\openquote}{%
  \tikz[remember picture,overlay,xshift=-15pt,yshift=-10pt]
  \node (OQ) {\quotefont\fontsize{60}{60}\selectfont``};%
  \kern4pt
}
\newcommand*{\closequote}{%
  \tikz[remember picture,overlay,xshift=15pt,yshift=10pt]
  \node (CQ) {\quotefont\fontsize{60}{60}\selectfont''};%
}
% select a colour for the shading
\definecolor{shadecolor}{named}{Maroon}
% wrap everything in its own environment
\newenvironment{shadequote}
  {\begin{snugshade}\begin{quote}\openquote}
  {\hfill\closequote\end{quote}\end{snugshade}}

%\usetheme{Darmstadt}
\usefonttheme[onlylarge]{structurebold}
\setbeamerfont*{frametitle}{size=\normalsize,series=\bfseries}
\setbeamertemplate{navigation symbols}{}

\setbeamercolor{background canvas}{bg=black}
\setbeamercolor{normal text}{fg=white}

\begin{document}
\begin{frame}
\begin{shadequote}
A common mistake that people make when trying to design something completely
foolproof is to underestimate the ingenuity of complete fools.\par\emph{Douglas Adams}
\end{shadequote}
\end{frame}

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.