3

I'm using the footnote package in conjunction with the hyperref package. However, when using more than one footnote per line in an environment (e.g. table, but also other floating environments), the hyperref package creates incorrect links (i.e. links point to the first page in the document).

Why do I want this? Because there is a (Word-)template for my thesis and my latex doc should exactly the same. Using hyperref is not required, but I'd like to work them correctly. Since I use different environments with the savennotes environment, a solution that works with all environments is required.

Please note: I don't want to use special packages like threeparttable or things like \tablefootnote because I need a solution that is applicable to other environments, not only tables. Also, I want to have the footnotes at the bottom of the page like text footnotes. Having them directly beneath the table is not an option (e.g. minipage).

In the MWE below, the last footnote in each row is correctly linked by hyperref, however, the others point to the first page:

\documentclass[12pt,a4paper,twoside,openany,fleqn]{book}

\usepackage{lipsum}

\usepackage{hyperref}

\usepackage{footnote}
\makesavenoteenv{table}

\begin{document}
\chapter{First Chapter}

\lipsum[1-3]

\begin{table}[htp]%
\begin{tabular}{lcr}
    My text\footnote{Incorrect 1}\footnote{Incorrect 2}\footnote{Correct 1} \\
    My text\footnote{Incorrect 3}\footnote{Correct 2} \\
    My text\footnote{Correct 3} \\
\end{tabular}
\caption{Test}
\end{table}

\lipsum[1]

\end{document}
  • I was just about to write »Don't do this!« but then i noticed: Already told you ;-) – Johannes_B Aug 1 '14 at 9:12
2

Don't do it. Depending on how your table floats the footnote counter get out of sync and the footnote text can end on other pages:

\documentclass[12pt,a4paper,twoside,openany,fleqn]{book}

\usepackage{lipsum}
\usepackage{footnote}
%\usepackage{hyperref}


\makesavenoteenv{table}

\begin{document}
\chapter{First Chapter}

\lipsum[1-6]abc\\cde\footnote{blub}

\begin{table}[t]%
\begin{tabular}{lcr}
    My text\footnote{Incorrect 1}\footnote{Incorrect 2}\footnote{Correct 1} \\
    My text\footnote{Incorrect 3}\footnote{Correct 2} \\
    My text\footnote{Correct 3} \\
\end{tabular}
\caption{Test}
\end{table}

bc\footnote{bla}
\lipsum[1]

\end{document}

Regarding hyperref: readme.pdf says about footnote:

This package is not supported, you have to disable hyperref’s footnote support by using option ”hyperfootnotes=false”.

1

Package footnotehyper but read its documentation.

0

please look at footmisc the multiple-Option could help to solve the problem

ftp://ftp.fu-berlin.de/tex/CTAN/info/translations/footmisc/de/footmiscDE.pdf

  • 1
    This seems better-suited as a comment, since the question is about the footnote package and this answer doesn't provide much detail. – Werner Mar 14 '18 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.