1

NOTE: Edited changes to bibliographystyle --> now \bibliographystyle{acm}

\documentclass{report}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{textcomp}
\usepackage{fixltx2e}
\usepackage[left=2cm,right=2cm,top=1cm,bottom=1.5cm]{geometry}
\usepackage{color}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{caption}
\usepackage{natbib}

\title{Literature Review: \\
\textbf{Farms: \\
 Supply}}


\author{ Jane }
\date{\today}

\begin{document}

\maketitle

\chapter*{\textit{Introduction}}
Some Text\cite{Nielsen2011}.

More text \cite{Byrne2003}.


\bibliographystyle{acm}
\bibliography{literature_review_references}


\end{document}

The citation is causing me trouble. I have another citation in a different section that worked the first time but after adding the second citation and running again, I now get the error stated at the top.

I have my compile settings as: Latex Bibtex Latex Latex View Pdf (evince)

Ok so I have also removed the PdfLaTeX command in my compile line.

The .bbl file looks like:

\begin{thebibliography}{1}

\bibitem{Byrne2003}
{\sc Byrne, B.~W., and Houlsby, G.~T.}
\newblock Foundations for offshore wind turbines.
\newblock {\em Philosophical Transactions: Mathematical, Physical and
  Engineering Sciences 361}, 1813 (2003), pp. 2909--2930.

\bibitem{Nielsen2011}
{\sc Nielsen, J.~J., and Sorensen, J.~D.}
\newblock On risk-based operation and maintenance of offshore wind turbine
  components.
\newblock {\em Reliability Engineering and System Safety 96\/} (2011),
  218--229.

\end{thebibliography}

Ok I changed the bibliography style so now it gets past Process started.

New errors!

  • citations undefined (again, this was working originally but now are undefined?)

    Package natbib Error: Bibliography not compatible with author-year citations.

closed as unclear what you're asking by Paul Gessler, Masroor, Guido, Benedikt Bauer, Mico Aug 4 '14 at 12:44

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.SX! Well, for one, you have nothing between \begin{document} and the first \end{document}, so nothing will be output. Later on, in the part of the file that's currently ignored since it's after \end{document}, you have unbalanced braces (the \chapter*{ is not closed). Furthermore, don't mix engines in your compile sequence (you start with latex and finish with pdflatex)—this will cause issues with graphics formats, etc. Choose the engine you need and use it all the way through. – Paul Gessler Aug 1 '14 at 14:10
  • 1
    Additional notes: You don't need the switch \makeatother unless you used the switch \makeatletter at some previous point in the file (because @ is "other" by default). If you want to use \maketitle to print the title page, you should set \title{My Title} and author{Name} somewhere before \maketitle. – Paul Gessler Aug 1 '14 at 14:20
  • 3
    also don't use fullpage (you are already using geometry which is better) and don't use epsfig (unless you are emulating documents written in the 1980's with the latex2.09 epsfig style) [latin 1] should be [latin1] (it works but only by accident) don't load geometry twice (the second one is ignored anyway but it is confusing and can lead to option clashes to load packages multiple times) – David Carlisle Aug 1 '14 at 14:37
  • Paul- thanks for spotting some of those mistakes! I think texmaker stuck the end document in there without me noticing. I'm confused though on compile sequence.. I had it just as Latex > Bibtex > Latex >Latex before and that wasn't work, and I saw somewhere a suggestion to add the pdfLatex and the evince command, which did make it work. What is the problem with doing this? – user3306583 Aug 1 '14 at 14:48
  • Also, I do have the title and author in before \maketitle, I just deleted it for the purpose of posting it here – user3306583 Aug 1 '14 at 14:49
1

I took your code and tried to compiled. Some errors appeared but they can be fixed doing the following (also take a look to he comments about \usepackage{fullpage}, \makeatother and \chapter*{ with no } at the end of the line.):

  • Add in preambule: \autor{your name}, \title{your report title} and \date{today}, this way the command \maketitle produces no error.
  • Remove the \end{document} command after \begin{document} line. You must have just one \end{document} in your file.
  • Close the brackets in \chapter*{\textit{Introduction}} command. Always check that every { has to end with a } at the end of the given command, in your code \chapter*{ open one and \textit{ opens another, then this line must end with }}, one for each command.

I compiled it, successfully with the next code, adding the details described before:

\documentclass{report}
\usepackage[latin 1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{textcomp}
\usepackage{fixltx2e}
\usepackage{fullpage}
\usepackage[left=2cm,right=2cm,top=1cm,bottom=1.5cm]{geometry}
\usepackage{color}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage{epsfig}
\usepackage{geometry}
\usepackage{caption}
\usepackage{natbib}
\makeatother

\title{test}
\author{you}
\date{}

\begin{document}

\maketitle

\chapter*{\textit{Introduction}}

 ...... cost of energy and can be up to 30\% \cite{Wilkes2012}. 

\bibliographystyle{apastyle}
\bibliography{literature_review_references}

\end{document}
  • @hkvictor - Thanks for this, I took note of the syntax errors and edited the code I had. I deleted my title and author name from the code that I posted purely for privacy reasons although this is included in my document. HOWEVER.. despite fixing these, I still have the problem originally stated: Process Started Process Exited with error(s) This just started after compiling successfully before! – user3306583 Aug 1 '14 at 15:01
  • I saw your edited post after answering this. When you remove personal information, just keep the commands (even empty or with false info, like I did). – hkviktor Aug 1 '14 at 15:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.