0

I am having difficulties setting up my system right in order to add the gnuplottex abbility. I followed this tutorial: adding gnuplot capability to latex and also used the mwe posted in this thread. In addition to that, I have spent quite some time researching without figuring out what the problem is.

I am using windows 8.1, miktex 2.9, texmaker 4.2 and gnuplot 4.6. I have added the command --enable-write18 to the pdflatex command and also tried different versions I have read about.

While compiling the mwe a warning is shown for a short moment about not finding the commands touch and rm. There is an entry in the log-file:

\verbatim@out=\write3
runsystem(touch w18-test-20148448.tex)...executed.

runsystem(rm -f w18-test-20148448.tex)...executed.


Package gnuplottex Warning: Shell escape not enabled.
(gnuplottex)                You'll need to convert the graphs yourself..

Does anybody know a solution how to add the abbility to compile gnuplottex codes with my system setup? Every and any hint is appreciated.

Thats how i enabled shell escape in TexMaker: enter image description here

  • I never used gnuplottex at all, but touch and rm are UNIX/Linux commands, at least in their origins. Perhaps you have to use cygwin or install the gnu environment to use this package or at least portions of it. The true error seems to be, that --enable-write18 does not work for your setup, perhaps due to security restrictions. – user31729 Aug 3 '14 at 23:03
  • @ChristianHupfer I have never used a Linux system and I am not familiar with these commands. I have tried to install cygwin once. for some reason it failed. how do I install the gnu environment? or do you have any idea how to come accros this security restrictions? – millo Aug 3 '14 at 23:30
  • @HarishKumar How do i enable -shell-escape while compiling? – millo Aug 3 '14 at 23:31
  • @HarishKumar Yes, I am using Texmaker 4.2. Could you post I line of code I can include into the mwe? – millo Aug 3 '14 at 23:38
  • @HarishKumar I added a print screen of how I added the --enable-write18 command. I tried like variations like -enable-write18, -shell-escape and --shell-escape. nothing worked so far. – millo Aug 3 '14 at 23:48
1

The problem has been solved by using \usepackage[miktex]{gnuplottex} and by deactivating the Use a "build" subdirectory for output files option by Texmaker

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.