5

I've just installed TeXLive from CTAN on Ubuntu 14.04, and following the instructions set up a local "equivs" so that Ubuntu thinks that TeXLive is properly installed.

However, when I use apt-get, such as

apt-get maxima

The system informs me that one of the NEW packages to be installed is texlive-binaries, which is one of the package listed in my equivs file. What's going on here and how do I fix things so that the system really and truly believes that texlive-binaries are installed?

  • Did you follow these instructions? – cfr Aug 5 '14 at 0:59
  • Yes, pretty much to the letter. And I just checked that "texlive-binaries" is listed in the equivs file. – Alasdair Aug 5 '14 at 2:14
  • What was the contents of your dummy package? Did you see the comment about login.defs? (It says that is for Debian but maybe worth checking.) Was the installation of the dummy successful? For my distro, maxima doesn't even depend on TeX Live - not even as an optional dependency, but only on texinfo. – cfr Aug 5 '14 at 2:51
  • Can you show me the output of apt-cache show texlive-local (or what the equivs package name is). Do you have Provides: texlive-binaries in the equivs config file? – norbert Aug 5 '14 at 3:46
  • apt-cache show texlive-local just gives the text you see here: tug.org/texlive/files/debian-equivs-2014-ex.txt, which does indeed include texlive-binaries. And now I'm getting some generic apt-get errors, which I need to fix. – Alasdair Aug 5 '14 at 7:15
1

This is just to have more space for a comment to Norbert.

BTW: Shouldn't tex-common be added to that equivs build file provided on the TUG web page (In my case we mount TL via NFS for easier maintenance, so I'd like to not have any of these packages installed in the system).

Just to be clear I do not have problems with maxima, my problem was with texmaker

$> apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

$> apt-cache policy maxima
maxima:
  Installed: (none)
  Candidate: 5.32.1-1
  Version table:
     5.32.1-1 0
        500 http://dk.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages


$> apt-cache show maxima
Package: maxima
Priority: optional
Section: universe/math
Installed-Size: 34056
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Camm Maguire <camm@debian.org>
Architecture: i386
Version: 5.32.1-1
Depends: libc6 (>= 2.15), libgmp10, libreadline6 (>= 6.0), libx11-6, gnuplot-x11
Recommends: maxima-share
Suggests: texmacs, maxima-doc, xmaxima, maxima-emacs, wish
Filename: pool/universe/m/maxima/maxima_5.32.1-1_i386.deb
Size: 5184540
MD5sum: a3864622dde8fd21bdfc4a1a61f08a6c
SHA1: 7e7958f54895cb5a327547444e3db6f52d941a8a
SHA256: 0caef9efbfe091ba557daa73deb9be9791be47b4e3ffe622c62c1b7c64fa4b1f
Description-en: Computer algebra system -- base system
 Maxima is a fully symbolic computation program.  It is full featured
 doing symbolic manipulation of polynomials, matrices, rational
 functions, integration, Todd-coxeter methods for finite group
 analysis, graphing, multiple precision floating point computation.
 It has a symbolic source level debugger for maxima code.  Maxima is
 based on the original Macsyma developed at MIT in the 1970s.  It is
 quite reliable, and has good garbage collection, and no memory leaks.
 It comes with hundreds of self tests.
 .
 This package contains the main executables and base system files.
Description-md5: a893a8f17245868a395fc5e31ea49aa5
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Just to be complete, here are the same one for texmaker eventough I now have installed it

$> apt-cache policy texmaker
texmaker:
  Installed: 4.1-1
  Candidate: 4.1-1
  Version table:
 *** 4.1-1 0
        500 http://dk.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status


$> apt-cache policy texmaker
texmaker:
  Installed: 4.1-1
  Candidate: 4.1-1
  Version table:
 *** 4.1-1 0
        500 http://dk.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status
root@orc21:/home/daleif# apt-cache show texmaker
Package: texmaker
Priority: optional
Section: universe/tex
Installed-Size: 6459
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Architecture: i386
Version: 4.1-1
Depends: libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libpoppler-qt4-4 (>= 0.20.1), libqt4-network (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libqtwebkit4, libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.1.4), texmaker-data (= 4.1-1)
Recommends: aspell, ghostscript, netpbm, psutils, latex-beamer, texlive-latex-extra, texlive-lang-english, hunspell-en-us | hunspell-dictionary | myspell-dictionary, asymptote, ibus-qt4
Suggests: texlive-lang-all
Filename: pool/universe/t/texmaker/texmaker_4.1-1_i386.deb
Size: 3532974
MD5sum: 7e93ac14207b67000b8a3d99cb7afa8f
SHA1: b5c99df964d8bfdfda2d8b1c30ae528672b6651b
SHA256: a7e01790204d096df6eae46dfd684c69dbfebcc542aa92cad0b60cf801be1530
Description-en: cross-platform LaTeX editor
 Texmaker is a clean, highly configurable LaTeX editor with good hot key
 support and extensive LaTeX documentation. Texmaker integrates many tools
 needed to develop documents with LaTeX, in just one application. It has
 some nice features such as syntax highlighting, insertion of 370 mathematical
 symbols with only one click, and "structure view" of the document for easier
 navigation.
Description-md5: c780af66e2bff60d1878797971e0737e
Homepage: http://www.xm1math.net/texmaker/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
  • I have the same problem when installing texmaker after running install-tl-ubuntu: github.com/scottkosty/install-tl-ubuntu I'm not convinced adding tex-common to the control file is the right solution. Last time I checked, there were binaries in tex-common package not installed with install-tl-ubuntu. However, at least one other person agrees with you that it should be added. For a discussion on the root problem of this, see github.com/scottkosty/install-tl-ubuntu/pull/10 – scottkosty Aug 21 '14 at 13:27
  • I'd be very interested in your thoughts on a solution if you have a chance to look at that issue. I tried a few different things and nothing worked. – scottkosty Aug 21 '14 at 13:28
  • Those binaries should not be used anywaht when you are using TUG Te Live. So the question is why do they come anyway – daleif Aug 21 '14 at 13:31
  • BTW: I just had a quick look a tthat page. Evince has more issues with apparmor. They should be fixed upstream, but I haven;t seen them rolled out in Ubuntu yet (Evince does not respect global dconf settings, /etc/dconf is completely ignored in the apparmor settings) – daleif Aug 21 '14 at 13:32
  • interesting. by "should be" do you mean "already are"? Also note that the following is a related Evince/apparmor ubuntu bug report: bugs.launchpad.net/ubuntu/+source/evince/+bug/888789 – scottkosty Aug 21 '14 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.