2

I'm having some problems getting TexLive Utility to work with the repository to update packages.

I received an error that said subfigure was an undefined environment in the RCS Journal template I was using, and some further googling told me that the package was deprecated. I copied in some elements of my preamble from my thesis where I know this environment had worked previously but no joy. I tried to update packages through TexLive utility from MacTEX and then received the error that the CTAN repository was running the 2014 version and I was still running the 2013. I elected to manually upgrade and followed the instructions found here:

http://tug.org/texlive/quickinstall.html

I have now got a 2014 folder in the correct directory alongside the 2013 folder that already existed from my current installation. As far as I can tell, everything worked fine (other than I had to sudo the installer on OSX).

I then added the binaries to my $PATH, as instructed, but I've never done this before and don't know if it is correct. It is meant to look like the below:

PATH=/usr/local/texlive/2014/bin/x86_64-darwin:$PATH

and so I exported that.

Using echo $PATH mine looks like:

/opt/subversion/bin/:/usr/local/texlive/2014/bin/x86_64-darwin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/texbin

My guess is that this is where at least part of my problem is coming from. But to continue, I thought I had solved this, so proceeded to test TexLive Utility, but alas the same error. I thought that perhaps the utility needed reinstalling so I redownloaded and installed MacTeX. Same problems (it was a long shot I knew :P )

TL;DR It seems to my naive brain, that the TexLive util is still trying to use the 2013 binary, rather than the new 2014 ones, but I don't know how to change what the application addresses.

Any help (ASAP) would be greatly appreciated.

  • This may sound very obvious, but have you tried using the TeX Distribution Preference Pane in System Settings? – Moritz Aug 5 '14 at 13:19
  • 1
    If you are using the MacTeX-based approach then you need /usr/texbin in your path before any other TeX system paths: as it stands it's last, which won't work. With MacTeX you shouldn't need to fiddle with the path anyway: not sure about 'vanilla' TL on Mac. – Joseph Wright Aug 5 '14 at 13:21
  • Yeah I did look in the preferences of the utility, but the only options I could really see that seemed even vaguely relevant was to switch the repository. Using a repository that is still on 2013 would be a quick fix (if there even are any now which I doubt), but wouldnt resolve the problem long term I guess? I'll try changing the PATH to move texbin. Out of interest, should I add this to .bash_profile, or export from terminal? Is one or the other a 'safer' or more rigorous option? – Joe Healey Aug 5 '14 at 13:59
  • I've updated PATH as you suggested, like so: /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/texbin:/usr/local/texlive/2014/bin/x86_64-darwin: such that the directory variables are in the correct order, but this hasn't solved the problem. Any other suggestions? I'm at a complete loss at the moment. – Joe Healey Aug 5 '14 at 18:16
  • Apologies for a double comment, it seems I can't edit my previous one. @Moritz, sorry I misunderstood your comment earlier (I was looking at the preferenced for TLU specifically), but nevertheless, in the TeX Distribution options in the General preferences, I can see both my 2013 and 2014 distributions (and 2014 is checked by default) but the only options I have is to start the texdistmgr in a terminal prompt, but still can't really see any useful options there. – Joe Healey Aug 5 '14 at 20:27
2

If you've installed TeX Live by some means other than MacTeX, then the default /usr/texbin path will no longer work correctly, as the symbolic links in the TeX Distribution prefpane (part of MacTeX, located in System Preferences.app) will not be set up. That preference pane basically just changes /usr/texbin to point at a particular TeX Live distribution.

The solution is to go into TeX Live Utility's preferences and click the "Choose…" button to select the location of your new binaries (i.e., containing directory of tlmgr) or drop the folder on the path control. For TL 2014 on a 64-bit system, the relevant directory would be /usr/local/texlive/2014/bin/x86_64-darwin. Perhaps I can add a note about this to the Help book (I assume you tried the Help menu, right?).

TeX Live Utility and other GUI applications do not inherit the PATH environment variable set in shell init files (e.g., ~/.bash_profile, ~/.bashrc). TeX Live Utility also goes to great lengths to avoid other ways that users try and set the PATH for all programs on the system, since this invariably causes hard-to-debug problems.

  • 1
    I was not able to do this successfully in a very similar situation (see my comment on your other answer). Unfortunately, this solution doesn't help with getting the preferences pane to recognize it, which I understand it isn't trying to, but the OP here is sort of about the same situation. – kcrisman Dec 5 '14 at 20:54
1

Ok, so after a couple of emails and finding this thread:

How can I tell TeX Live Utility where my TeX distribution is?

It seems like the only option that worked was to completely eradicate TeX from the system and do a brand new install of MaxTeX distro, removing all GUI apps, and all distros from the /usr/local/texlive. I couldn't figure out how to tell TLU to look in the root directory that that link talks about so I just bit the bullet and reinstalled.

Maybe someone out there has a more elegant solution and actually knows how to fix it so that TexLive Utility addresses the correct distribution without wiping everything out (luckily I dont really have too many settings that need reconfiguring), but this ultimately solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.