3

So, I know there's already a question about this (Hyperlink in moderncv with acrobat reader) but I have tried the solutions there (updating and security settings) and it still doesn't work and I don't think that it's an Adobe problem since I have other documents (not moderncv) where the links work perfectly.

I am using Adobe Acrobat Pro XI. The links do work on Preview. Here's a MWE:

\documentclass[11pt,a4paper,dvipsnames]{moderncv}

\moderncvtheme[blue]{classic}
\usepackage[scale=0.8]{geometry}
\usepackage[utf8]{inputenc}

\firstname{First name}
\familyname{Last name}
\title{Curriculum Vitae}
\address{Address line 1}{Address line 2}
\mobile{Phone}
\email{Email}

\AtBeginDocument{\hypersetup{colorlinks, urlcolor=NavyBlue}}

\begin{document}

\section{Education}
\cventry{Year}{Degree}{University}{Location}{GPA. \href{http://www.google.com}{Google}}{}


\end{document}
3
  • The link works without a problem for me (Ubuntu 12.04, Document Viewer 3.4.0). So I suppose it is an Adobe problem.
    – Habi
    Aug 6, 2014 at 14:08
  • if it is an Adobe problem it is only when I work with moderncv and not with other type of tex documents.
    – an1234
    Aug 6, 2014 at 14:52
  • 1
    BTW, I would use rather https://www.google.com/ than http://www.google.com. Oct 6, 2014 at 10:16

1 Answer 1

2

On the moderncv.cls file I removed the baseurl= http:// option under hypersetup and it worked. I'm not sure why but it did.

1
  • But if baseurl= is set to http:// already, can't you than just leave these out in your \href commands? Or change them to https:// as Kurt says by using hypersetup in your file...
    – Ronny
    Dec 2, 2015 at 8:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .