I work on Windows 7 X64 and since the latest update of LaTeXTools plugin for sublime text 2, the build (Ctrl+B) is failing with the following:

[Compiling E:\Users\Seif\Desktop\1tsss\first.tex]

TraditionalBuilder: Invoking texify...

And nothing is compiled!

I have followed the instructions to issue the command from the command palette "Reconfigure and migrate settings".

I'm using the default generated LaTeXTools.sublime-settings with the following:

"windows": {
    // Path to tex & friends. "" is fine for MiKTeX
    // For TeXlive 2013 (or other years) use
    // "texpath" : "C:\\texlive\\2013\\bin\\win32;$PATH",
    "texpath" : "",
    // TeX distro: "miktex" or "texlive"
    "distro" : "miktex"

The PATH variable contains both the path to MixText bin folder (E:\Program Files\MiKTeX 2.9\miktex\bin\x64) and the path to SumatraPDF (E:\Program Files (x86)\SumatraPDF).

If I issue the same texify command plus the sumatrapdf from within the prompt command-line (cmd.exe) it works.

E:\Users\Seif\Desktop\1tsss> texify -b -p --tex-option="--synctex=1" filename.tex && sumatrapdf filename.pdf

I followed many threads searching for a solution but nothing succeeded in my case. A very similar question is here but all solutions there don't work. I appreciate your help.

2 Answers 2


Solved it! After a long search I figured out that the problem has been with a secondary language being set for Non-Unicode programs in the computer. To fix this just follow the steps:

Control Panel -> Clock, Language & Region -> Region & Language -> Administrative -> Language for non-Unicode programs

and set it from your old language to English using the Change System Locale button. Restart needed. Done!

  • I'm glad to see you could find a solution for your trouble. I use Sublime Text in Windows, gnu/linux and Mac and I never saw this before. Now I know what to do.
    – Aradnix
    Commented Aug 10, 2014 at 5:07
  • I encountered the same problem, but do not have admin access on my machine (and thus cannot open said panel). Any suggestions?
    – ben
    Commented Nov 9, 2014 at 13:30

Surely to have many features to edit tex-files needed to do all the steps that you say, but for the compiler to work from within the editor is not needed so much work. Both step may discourage those (if not known) want to use it. Just go to:

 Tools -> Build System -> New Build System

and in the new tab that opens add:

"cmd": ["pdflatex", "$ file_name"]
"selector": "text.tex.latex"

and when you save choose as file name:


(keeping the directory configurations that the editor offers).

And without even restarting the Sublime Text compiling a tex-file with:


Well I hope it will be useful.

  • Thank you Aradnix for your response. I performed your steps but the program compiles only once. The second time I press ctrl+B it gives an error: Traceback (most recent call last): File ".\sublime_plugin.py", line 337, in run_ File ".\makePDF.py", line 193, in run File ".\subprocess.py", line 949, in terminate WindowsError: [Error 5] Access is denied and I must close it and open again to compile. Please any further help?
    – AboAmmar
    Commented Aug 7, 2014 at 12:48
  • Are you the Admin in the windows machine where you use Sublime Text or are you only a common user? I searched about the error, but it seems [a python error] (docs.python.org/2/tutorial/errors.html) [Take a look at this] (stackoverflow.com/questions/20395003/…). Good luck.
    – Aradnix
    Commented Aug 8, 2014 at 15:58
  • Yes I'm Admin, but still having the error message below: 'texify', '-b', '-p', '--tex-option="--synctex=1"', 'first.tex' ('texify', '-b', '-p', '--tex-option="--synctex=1"', 'first.tex') Traceback (most recent call last): File ".\sublime_plugin.py", line 337, in run_ File ".\makePDF.py", line 193, in run File ".\subprocess.py", line 949, in terminate WindowsError: [Error 5] Access is denied
    – AboAmmar
    Commented Aug 9, 2014 at 15:56
  • 1
    At last!! See my solution.
    – AboAmmar
    Commented Aug 10, 2014 at 1:04
  • 1
    I don't forget to thank Aradnix for giving me the hope.
    – AboAmmar
    Commented Aug 10, 2014 at 1:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .