4

I'm using MikTeX 2.9 (pdflatex) and WinEdt 8.2. I know that all output files such as .tex, .pdf, .dvi, .log are important and I cannot simply delete them so I would like to ask how to get files (.pdf and .tex) in one directory and other files in another directory.

I have already found very similar questions here with answers, but I was not still able to sort it out. I have found out that I should use --output-directory=dir and --aux-directory=dir but I don't exactly know how to work with it. Could anyone help me with this problem?

0

Click on the Options menu and select Execution modes…. In the popup window, click on the TeX Options tab. There you'll can choose your TeX aux directory, like in this window:

enter image description here

With such a setting, the aux directory will be a TeXAux subdirectory of your input file (or of your master file if you have one). If you deselect the Use %P … option underneath, the TeXAux directory will be automatically created if it doesn't exist yet.

I suggest, if not yet done, to create a localtexmf directory: this is where personal file styles, or packages that you install yourself (not through MiKTeX Package Manager) should be stored. You'll create one with MiKTeX Options, root tab:

enter image description here

and then let WinEdt know about it through the Execution Modes interface.

  • You first have to create it and register with MiKTeX Options. Then, Execution Modes …, you select it by clicking on the Browse… icon on the right. The directoty will appear in the line just under TeX Local Root, and clicking on the Apply button, it also will appear in the line next to ok. That's all. Btw, D\… comes from my personal choice to have my TeX system on a separate partition. You can put your Local TeX root anywhere you please. The only constraint is to respect the TDS organisation. – Bernard Aug 9 '14 at 16:26
  • "let WinEdt know about it through the Execution Modes interface" means the above procedure will validate this TeX Local root also for WinEdt, so that the internal macros of WinEdt can use it if required. – Bernard Aug 9 '14 at 16:29
  • You're mixing up two distinct problems: enabling a TeX local root has nothing to see with the problem of having a directory for auxiliary files. It was just an advice for make installation clean. Did you follow the first part of my answer as to creation of a TeX Auxiliary Output Folder? – Bernard Aug 9 '14 at 18:21
  • Well, it's probably working now. I was confused by the picture, because there Use%P is selected, but it needs to be deselected...Anyway, thanks for your help and being patient. – Laura Aug 9 '14 at 19:12
  • You're welcome. WinEdt is very rich-featured and it's not so easy to master. What do you mean with ‘probably’. Do you see a TeXAux directory and aux files in it with Windows Explorer? – Bernard Aug 9 '14 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.