8

I'm working with TexStudio 2.7, and trying to get the spell checker to work.

I've tried downloading a new dictionary (as in here), as well as modifying the .aff file (as suggested here), but this doesn't seem to work..

It's not that the checker doesn't offer any corrections, but it's corrections are just not in English. Here are some of its offers:

  1. algorithm -> Algorithmen, Algorithmus, algorithmisch
  2. introduced -> eintrocknend
  3. The -> Theo, Tee, Ehe, Che, Tue.

*****Any ideas as to why this happens and how to make it work?*****

13

Did you set the standard language to "en_GB" or "en_US" ? Please check under "options/configure TeXstudio/General" in section "Dictionaries"standard language

7
  1. You can set the default dictionary "options/configure TeXstudio/General". This will be used for all files (if you do not choose one of the options below to override it).

  2. You can select the current dictionary of a file via the language selector in the status bar. This is a per-file setting and is not stored when closing the file. Language selector

  3. You can use a magic comment % !TeX spellcheck = en_US to permanently assign a dictionary to a file. TeXstudio checks for this comment when loading a file and automatically sets the current dictionary for the file accordingly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.