1

This is potentially a duplicate of this tex.se question, but I tried all the advice with still no solution.

I am on 64-bit Windows 8.1 Update with gvim 7.4, Python 2.7.7 (Anaconda 2.0.1 32-bit), and pywin32-214. I think the pywin is a little dated, but works best with my vim-R-plugin for use with R.

When I type \cite{Fama} and press F9 I get a flash, and it looks like it goes from normal back to insert, but I get neither an error nor a lower half split with matched .bib file entries. But my \ref{} completion works great. I use the *latexmain file setup, but the problem (i.e., no citation completion) works whether I do this or some MWE.

I have the following in my _vimrc file.

set grepprg=grep\ -nH\ $*
let g:Tex_BIBINPUTS='C:/Users/richa_000/texmf/bibtex/bib/library.bib'

I also have GNUgrep in path and :!grep -V returns the following.

C:\windows\system32\cmd.exe /c (grep -V)
GNU grep 2.5.4

Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Hit any key to close this window...

I also have Python in path and :python import sys; print(sys.version) returns the version listed above.

I also vim-pandoc and can get citation completion there with <C-x> <C-o>.

Any idea how to fix this? Thanks!

  • I am now having the same problem. Damn windows 8.1... – Troy Woo Oct 22 '14 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.