2

I have trouble executing the nomenclature. I saw many posts in the internet like Using package nomencl and List of symbols or abbreviations (nomenclature) but I am unable to do it.

I would like to create a list of symbols to my report that I am writing. I am using Windows 7 and TeXnicCenter. I do not know what these sequences mean?

latex filename.tex
makeindex filename.nlo -s nomencl.ist -o filename.nls
latex filename.tex

Any help please? What should I do?

2
  • Those are the commands you enter at the command line although your editor probably has a button you use to compile the basic document ((pdf)latex filename.tex). If you can't run the makeindex line using your editor, use the command line or configure your editor appropriately. Somehow or other, you need to run those commands.
    – cfr
    Commented Aug 13, 2014 at 1:12
  • I never try to compile nomecl in Windows, for me is more comfortable to do it in a gnu/linux terminal. But surely you could run those commands inside the command prompt. I don't use TeXnicCenter so I can't help you with the technical parts of your editor. Please read carefully the documentation of the nomenclpackage, there explains how to compile and get your lists correctly. Good luck.
    – Aradnix
    Commented Aug 13, 2014 at 5:54

2 Answers 2

5

In TeXnicCenter you can add a new profile for compiling with a nomenclature.

Press alt+F7 to open the dialog windows for the profiles. Choose your standard profile, copy it with the button copy and give it a new name, like "LaTeX-PDF-nomencl".

Now check that you have clicked on register "(La)TeX". In the last line you can add your arguments to be given to makeindex: your arguments (see your command above) "filename.nlo -s nomencl.ist -o filename.nls" translate to ""%tm.nlo" -g –s nomencl.ist -o “%tm.nls" then TeXnicCenter can work with it.

I have only a german version of TeXnicCenter here but I guess a screenshot will help you.

enter image description here

Don't forget to check the log file for errors or warnings for your nomenclature.

A little bit late this answer, but I hope it can help you.

2

I quote the accepted answer, but for me (TeXnicCenter 2.02 (stable) 64bit, MiKTeX 2.9, Win 10) the option -g was not correct. To get the Nomenclature page printed, I edited the command line argument of Makeindex in the build output profile to be just:

%tm.nlo" -s nomencl.ist -o "%tm.nls"

Cheers.

2
  • I believe the -g was recommended in the docs for German users, so yes this is correct.
    – R.K.G.
    Commented Apr 18, 2017 at 17:18
  • There is some " missing in the beginning. Commented Jul 24, 2021 at 22:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .