13

I have a search for this problem but all I could find was the case of reference citations in document spilling over, not the bibliography.

Quite simple problem I hope... In my bibliography some of the journal names are spilling over the right margin:

names

The italic journal names are spilling over, I am using package cite and \bibliographystyle{unsrt}. I am using \usepackage{microtype}.

Any idea whats causing this? A MWE of just one article that causes this is,

\documentclass[11pt,a4paper]{report}
\usepackage{cite}
\usepackage[utf8]{luainputenc}
\usepackage{microtype}

\begin{document}

In papers \cite{Ferri2004}

\bibliographystyle{unsrt}
\bibliography{testbib} 
\end{document}

with the bibtex file testbib.bib as:

@article{Ferri2004,
author = {Ferri, F. and Magatti, D. and Pescini, D. and Potenza, M. a. C. and Giglio, M.},
doi = {10.1103/PhysRevE.70.041405},
file = {},
issn = {1539-3755},
journal = {Physical Review E},
month = oct,
number = {4},
pages = {041405},
title = {{Heterodyne near-field scattering: A technique for complex fluids}},
url = {http://link.aps.org/doi/10.1103/PhysRevE.70.041405},
volume = {70},
year = {2004}
}

Thanks.

5
  • Can you include a minimal working example (MWE) to give us a basic idea of your environment?
    – Johannes_B
    Aug 13, 2014 at 7:31
  • You don't need to use luainputenc. LuaTeX expects utf8 encoding.
    – Johannes_B
    Aug 13, 2014 at 7:52
  • It works with biblatex. Should be a reason to switch ;-)
    – Johannes_B
    Aug 13, 2014 at 7:56
  • This is a very much cut down version of my thesis for which this problem occurs. I cant remember why I have that in there but I removed it and get no compile errors. Thanks. it still gives me the spilling bibliography though. Aug 13, 2014 at 7:57
  • @Johannes_B It is often needed for printing umlauts.
    – percusse
    Aug 13, 2014 at 8:45

6 Answers 6

3

I had this same problem with my dissertation. The fix for me was loading the fontspec package before the microtype package. For example:

\usepackage{fontspec}
\usepackage{microtype}

The microtype documentation says:

With LuaTeX, load fontspec before microtype.

2

(Too long for a comment, hence posted as an answer.)

An observation up front: Given that your bibliographic entries have doi and url fields, you should consider using the unsrtnat bibliography style along with the natbib citation management package; the venerable unsrt style simply ignores those fields. If you load natbib with the option numbers, you needn't load the cite package.

I am able to reproduce the overfull lines if (a) the microtype package is loaded and (b) the unsrt style is used. I must confess I don't understand what's going with microtype here. At any rate, if you want to keep using microtype you may want to switch to the unsrtnat style (and also load natbib instead of cite).

Finally, as has already been remarked by @Johannes_B, don't load the luainputenc package. When using LuaLaTeX, do make sure that all input files are utf8-encoded.

2

@OSE's answer solve it for me.

However the more general case is potentially good to disable protrusion before the bibliography -- or any other section it is screwing up.

\microtypesetup{protrusion=false}
\bibliography{testbib} 

Take a look at section 9 of the microtype manual, turning protrusion off can often be a good thing.

I expect that \usepackage{fontspec} before \usepackage{microtype} more generally fixes it.

0

For me the fix was removing this package: \usepackage{apalike}

I realize that this isn't included in your project but it helped me when I experienced the exact same issue so I'm sharing for anyone in my same situation.

0

In my case \newgeometry solved the problem.

Something like this:

\newgeometry{top=32mm, bottom=27mm, left=40mm,right=15mm}

\bibliography{ref}

also you can try this:

%SHIFT HORIZONTAL MARGIN ON EVEN/ODD PAGES
\addtolength\oddsidemargin {-1cm}
\addtolength\evensidemargin {-1cm}
\bibliograph
0

I had the same problem, and I started removing packages one by one until it was fixed. In my case it was because of the {ulem} package.

I changed the line:

\usepackage{ulem}

by:

\usepackage[normalem]{ulem}

And it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .