I have just installed TeXnicCenter on my new computer and I am trying to use LaTex => ps => pdf profile as I was using this with my old computer. I checked all profile settings from output profile and they match settings of my old computer. However for some reason, the .pdf file is not being created. The only files created are .aux, .bbl, Performance monitor file, .dvi, Text, and .dwg TrueView PostScript support file.

Can someone help me with this please?

  • You might have a look at this for the correct compilation sequence. From what you say it seems the step between dvi and ps is missing/broken. If all you want is a pdf output and you have no other reasons to go via dvi, consider pdflatex as a single step, rather than the long sequence you're using. – greyshade Aug 13 '14 at 10:42
  • thanks for your reply. i have figures in .eps format. can i use pdflatex in this case? – natt010 Aug 13 '14 at 10:49
  • yes. see here and here. – greyshade Aug 13 '14 at 10:55
  • thanks, i did as suggested but instead of the figures i am getting an empty box with the link to my .eps file. in fact i've got some errors while compiling – natt010 Aug 13 '14 at 11:33
  • i think the problem is with the write18 or shell escape. i don't know how to enable these can you advise please? – natt010 Aug 13 '14 at 11:34

To solve this problem you have to do several things.

First prepare your code to be compilable:

% pdftex % be carefull!!: with this option: 2 errors, without: 0 errors
]{graphicx} % for \includegraphics
\usepackage{epstopdf} % to change .eps to .pdf
\epstopdfsetup{update} % conversion only if no .pdf file already created

Now you should see the picture in pdf:


In line 5 of the mwe I added \usepackage{epstopdf} to prepare the possibility to change .eps images to .pdf images. Line 6 starts epstopdf only, if the changed "epstopdf" file does not exist. (Please see documentation with texdoc epstopdf). Because you gave no MWE I can only guess what you are doing, here just a remark. In the epstopdf documentation is showed to call package graphicx with option pdftex. That causes in 2 errors. Without the option the code compiles with only one warning, but wanted document!

Second you have to prepare TeXnicCenter to be able to do what you want. Prepare a new output profile, for example LaTeXshellescape=>PS=>PDF.

Copy the original LaTeX=>PS=>PDF to the new profile, and do the following changes:

  1. Add -shell-escape in arguments for the compiler (see red marking):

Configuration (La)TeX

Please see, that I changed "%bm" to "%tm" (see red markings).

  1. Open register Nachbearbeitung (sorry, do not know the english name, it is the third one, see image) and check if you see:

Configuration Nachbearbeitung

With theese changes you will get the following compiled result without errors:

Result of MWE

Alternative method with dvipdfmx

You can also use an alternative method with dvipdfmx (see Project KTug.org or CTAN:dvipdfmx). But then you use the way from .dvi to .pdf!

MiKTeX is not able to run several script, because Windows has no installed perl or ... interpreter. But you can use the program dvipdfmx.exe (see windows directory C:\Program Files\MiKTeX 2.9\miktex\bin\x64) to get the same result. Use dvipdfmx --help to see all possible options. I need none of them for the example here.

With the following MWE (please see that epstopdf is missing)

\usepackage{graphicx} % for \includegraphics

Now you should see the picture in pdf:


and the following configuration (profile LaTeXdvipdfmx) for TeXnicCenter you get the wanted result.

Copy LaTeX=>DVI=>PDF to LaTeXdvipdfmx, do not add -shell-escape, change %bm to %tm (see red markings).

dvtpdfmx configuration 1

Now click on Nachbearbeitung and change there dvipdfm to dvipdfmx to call program dvipdfmx.exe.

enter image description here

Click ok and compile the mwe. The result is the same I showed above ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.