3
\documentclass{beamer}

\usetheme{Madrid}
\begin{frame}{Introduction}
\begin{itemize}
\item<1-> abc
\item<2-> def
\end{itemize}
\begin{definition}<3->
ghi
\end{definition}
<4->jkl
\end{frame}

\end{document}

I want the plain text "jkl" to appear last, after the two "items" and one "definition". But what I did here didn't work. How can I fix it?

3

You have to provide some command to make the text 'variable'. Here, the obvious option is \uncover:

\documentclass{beamer}
\begin{document}
\begin{frame}{Introduction}
\begin{itemize}
\item<1-> abc
\item<2-> def
\end{itemize}
\begin{definition}<3->
ghi
\end{definition}
\uncover<4->{jkl}
\end{frame}
\end{document}

You could also consider \only, but it would alter vertical spacing so is unlikely to be what you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.