0

I'm trying to use apacite to manage my references style. I'm satisfied with the style of the bibliography, but not the citations. They appear as a number between square brackets, which is not, by any means, close to the APA citation style. How am I supposed to get the citations to appear as actual APA-style ones? There is also something weird which may be relevant, and it's that the only commands I can use for citations are \cite and \citep (which both result in the output describred earlier) - if I try to use \citeA, the references are taken as error because of, supposedly, not being defined.

This is how I'm setting it up:

\usepackage[index]{apacite}
\bibliographystyle{apacitex}

I am using pdfLatex as compiler on ShareLaTeX.

5
  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – mvkorpel
    Aug 15, 2014 at 11:29
  • @mvkorpel Just checked it locally on an MWE written from scratch and it works flawlessly. Definitively it has something to do with ShareLaTeX rather than with TeX itself. I have uploaded the project to Mega (mega.co.nz/#!UMdAhDbS) and will post the key below. In the meantime, I'm going to try to fix the errors that arise when I try to compile the project locally since, althought this would not answer the question, it would indeed fulfill my necessities anyway. Aug 15, 2014 at 11:56
  • AgSUUPrFFDhVz8ULGQxoZkohnf8j-jiWCzIumhLTe2g Aug 15, 2014 at 11:56
  • 1
    I took a look at the list of packages loaded in your document. This looks like an issue in the way you are using apacite and natbib. Please read the relevant part of the apacite manual: "Using natbib for citations".
    – mvkorpel
    Aug 15, 2014 at 12:26
  • 1
    Yes, I just figured out about that too. I'll post a self-answer. Aug 15, 2014 at 12:35

1 Answer 1

2

I was using the wrong options for natbib. Upon removal of the "square" and "number" options, citations now appear in the proper format (I'm using "sort" and "round").

2
  • 1
    You could try using the natbibapa option of apacite instead of explicitly loading natbib. According to the manual, this "better satisfies the APA rules and fixes some compatibility problems".
    – mvkorpel
    Aug 15, 2014 at 15:25
  • 1
    I haven't realized any major differences but, since the source citing the option is reliable, I agree that it is better and have adopted it. Thanks again. Aug 16, 2014 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.