2

I updated my operating system on my laptop from Ubuntu 12.04 to 14.04 yesterday, and now I cannot compile my .tex files. I always get the following message.

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian) restricted \write18 enabled. ---! /var/lib/texmf/web2c/pdftex/latex.fmt doesn't match pdftex.pool (Fatal format file error; I'm stymied)

I tried searching for some information and found the suggestions offered here. I tried first running

fmtutil --all

but that didn't work, so next I tried

sudo fmtutil-sys --all

but that also didn't work. I also found this thread asking essentially the same question, but the focus there seemed to be on having a "portable install." I'm not exactly sure what a portable install is, but I don't think I have that on my laptop so I don't know if the answers on that thread are of any use to me.

7
  • 2
    It might be better to remove TL (you are using 2013) and reinstall to get 2014 instead.
    – daleif
    Aug 19, 2014 at 11:25
  • What is the best way to remove texlive and reinstall. The reason I ask this is that (from my perspective) the texlive files are stored in all these strange locations that I don't know of and I want to make sure I don't have any errors caused by multiple files if I update to 2014. Aug 19, 2014 at 11:33
  • The thing here is that with a 'managed' TeX Live install the problem is more one at the Ubuntu end than the TeX one ('normal' TeX tools don't apply). I'd use the Ubuntu package manager to remove anything with 'TeX Live' in the name, as suggested by @daleif, then re-install.
    – Joseph Wright
    Aug 19, 2014 at 11:54
  • I haven't yet removed the old texlive install. Even if I reinstall texlive, I'm not sure I'll get the 2014 version. The one listed in the ubuntu packages is version 2013.20140215-1. Aug 19, 2014 at 12:14
  • 4
    This question appears to be off-topic because it is solved by re-installing TeXLive.
    – yo'
    Aug 20, 2014 at 15:26

1 Answer 1

0

I ended up just removing my old texlive installation and reinstalling it fresh. Not the most elegant solution, but it seems to have worked.

Not the answer you're looking for? Browse other questions tagged or ask your own question.