1

I had a large linguistics example document with example text from many different languages, which stopped compiling when I transferred it to a new Mac (with all the same software and TeX distribution). The Chinese and Japanese sections were the culprits, yet Korean displayed fine (all using xeCJK). I finally tried removing \noindent (as well as the code indentation) from the beginning of the Chinese and Japanese sections and it suddenly worked fine. But why?

MWE:

\documentclass[11pt]{article}

\usepackage{fontspec}

\usepackage[fallback]{xeCJK}

\setCJKmainfont{SimSun}

\setCJKfallbackfamilyfont{\CJKrmdefault}{AppleMyungjo}

\begin{document}

\section{Chinese (Traditional)}

構詞學

\section{Japanese}

語(ご)とは

\section{Korean} 

    \noindent 단어(單語)

\end{document}

This version works. With the \noindent before the Japanese and Chinese sections, it does not work.

closed as unclear what you're asking by Troy, CarLaTeX, Schweinebacke, Stefan Kottwitz Dec 29 '17 at 19:18

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.SX! I get the same output with or without \noindent in all three sections. What do you mean by “it does not work”? – egreg Aug 22 '14 at 8:54
  • The code works for me (with or without \noindent added). And the \noindent is redundant since v3.2.11 (r472). You are probably using an old version of xeCJK. Please update your TeX system (update all packages) and try again. – Leo Liu Aug 22 '14 at 16:22

Browse other questions tagged or ask your own question.