2

The memoir class's \DoubleSpacing command without an asterisk (*) is supposed to double-space the text but not the footnotes or float text. However, when the arabxetex package has been loaded, this functionality is disrupted, such that in addition to the main text, the footnotes are also double-spaced (floats are still single-spaced as expected).

I am not the first to point out that sometimes \DoubleSpacing erroneously produces double-spacing in the footnotes; someone already did a year ago -- but that question was closed without being answered. I hope that now that I have identified the specific package (or at least one of the packages) which causes this problem, the question will be easier to answer.

The following example file, compiled with xelatex (MacTex 2014), produces double-spaced footnotes; I would like it to produce single-spaced footnotes (while keeping the package arabxetex).

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[12pt,article,oneside,letterpaper]{memoir}
\usepackage[american]{babel}
\usepackage{fontspec}
\setromanfont[Mapping=tex-text]{Times New Roman}

\usepackage[novoc,fdf2alif,utf]{arabxetex}

\DoubleSpacing

\begin{document}

Blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah.\footnote{Blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah blah.}

\end{document}

Update (2014-09-05)

As was pointed out in the comments below, the real problem is a conflict between the bidi package and memoir's \DoubleSpacing command; once bidi is removed, the command functions as described in the memoir documentation (text double-spaced, footnotes single-spaced).

Just to be clear, I am not requesting a comprehensive fix of this problem, which I imagine would involve a modification of the bidi package itself. My question is simply whether there is a decent work-around which would allow me to achieve the desired result. (So far I have met with no success fiddling with \baselineskip and the other parameters described in memman.pdf §3.3.2 = pp. 48–49.)

  • Without looking at the code. My guess is that arabxetex messes with footnotes and thus overrides the memoir definition. In that case there is nothing memoir can do. – daleif Aug 23 '14 at 10:44
  • Perhaps one of the author/maintainers of arabxetex would know where to look? @Vafa Karen-Pahlav (who seems to be a user here on the TeX Stack Exchange) and François Charette are listed on CTAN; does anyone know how I might get in contact with one of them to inquire about this issue? – Alex Roberts Aug 24 '14 at 19:34
  • Is it possible for you to provide an example that only depends on font available i, say, TeX Live. I cannot compile your example. – daleif Aug 25 '14 at 7:20
  • 1
    Looking at arabxetex it is clear that it does not mess with footnotes. But something in bidi does. Removing fontspec, \setromanfont and replacing arabxetex with bidi shows the problem. The footnotes are double spaced. bidi redefined lots of things in various classes, so small details like this easily gets lost. – daleif Aug 25 '14 at 7:25
  • Thank you, @daleif! I see what you mean. Perhaps the author of bidi (listed as @VafaKhalighi) would know how to fix this? – Alex Roberts Aug 26 '14 at 16:46
2

Before \usepackage{arabxetex}, put

\PassOptionsToPackage{extrafootnotefeatures}{bidi}
  • An example would be much more useful! – user31729 Sep 13 '14 at 9:16
  • I have tried Vafa Khalighi's suggestion on the MWE which I provided in the original question and found that it resulted in precisely the output I had been seeking. I have accordingly marked this as the answer. Many thanks to @daleif for pinpointing the problem and to Vafa Khalighi for the solution! – Alex Roberts Sep 14 '14 at 14:39
  • I prefer no extra space between footnotes, so I have also added the line \setlength{\footnotesep}{9pt} (using the 12pt option for memoir as in my MWE). – Alex Roberts Sep 14 '14 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.