1

I recently upgraded my Linux Distribution to Ubuntu 14.04 and received the following error when I tried installing a package using tlmgr:

(running on Debian, switching to user mode!) tlmgr: The TeX Live versions supported by the repository http://ctan.uib.no/systems/texlive/tlnet (2014--2014) do not include the version of the local installation (2013).

I thus upgraded my TexLive Distribution to 2014 using install-tl as described here: http://www.tug.org/texlive/quickinstall.html

When I now execute tlmgr update --self, I receive the same error as above! tex --version yields this:

TeX 3.1415926 (TeX Live 2013/Debian) kpathsea version 6.1.1 Copyright 2013 D.E. Knuth.

The version seems to be unchanged! What is this noob doing wrong?

2
  • 3
    Did you set the according $PATH in your .profile (or whereever you prefer)?
    – Johannes_B
    Aug 23, 2014 at 9:31
  • Yup. echo $PATH yields /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/texlive/2014/bin/x86_64-linux/ Aug 23, 2014 at 9:41

1 Answer 1

4

You have 2 versions of TeX Live installed: one installed with install-tl and one installed using Debian's package manager. The latter is first in PATH. You should do two things. First, your PATH should have the texlive bit first. (I would do this so it does not affect root's PATH.) Second, you should get rid of the Debian installation to avoid confusion and install a dummy package to keep your package manager happy. There is a full explanation in the question on installing vanilla TL from upstream on Debian/Ubuntu systems.

3
  • I created the fake packages using equivs and modified $PATH. tex --version yields TeX 3.14159265 (TeX Live 2014) kpathsea version 6.2.0 Copyright 2014 D.E. Knuth. echo $PATH yields /opt/texbin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games. YET, when I try sudo tlmgr install <package>, I get the same error as above : lmgr: The TeX Live versions supported by the repository ctan.uib.no/systems/texlive/tlnet (2014--2014) do not include the version of the local installation (2013).!!! Aug 24, 2014 at 9:05
  • Also, I don't think I'm looking for the other TeXLive installation in the right place. I can't find it in /usr/local/texlive. Have I really succeeded in removing it then? Aug 24, 2014 at 9:08
  • @KurtVonnegut So I think you have not succeeded in removing Debian's TL. Try searching your installed packages in your package manager for texlive to find the names of the packages you need to remove. sudo may be using a different PATH. Try specifying the full path to tlmgr.
    – cfr
    Aug 24, 2014 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.