1

I am trying to cite a source in my file. I want it to come out as "(see Author et al. (Year) for a discussion)". I already have the natbib package in use, and I set my \bibliographystyle to {plainnat}. However, what comes out when I generate the pdf file is:

(see (author?) [1] for a discussion)

with "(author?)" in bold text. How can I show the author/s and the year instead of the reference number?

3

After loading natbib, but still in the preamble, provide the instruction

\setcitestyle{authoryear,round}

Alternatively, you could load the natbib package with the options authoryear and round:

\usepackage[authoryear,round]{natbib}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.