1

The problem I'm having with Kile on Windows 7 (x64) is the following:

each time I need to close the compiled PDF file manually to run the "QuickBuild" command, since Kile can not overwrite the existing file while the PDF file is open (it just gives an error), and when the compilation is done, Kile does not open the PDF file automatically.

Also, even if the PDF is closed the "PDFTex" command is not working at all, it just gives an error during compilation. I guess it is still a problem with overwriting.

Any ideas?

  • 2
    Welcome to TeX.SX. Not all PDF viewers lock the PDF, Sumatra is one example of a viewer that does not. Which error do you get? Assuming you're writing LaTeX (your code starts with \documentclass), you should probably use PDFLaTeX, not PDFTeX. – Torbjørn T. Aug 24 '14 at 12:14
  • Thanks for the suggestion! The PDFLatex, instead of PDFTex worked smoothly (I am using LaTex starting with \documentclass). However, while the PDF is open (in Okular) running PDFLatex does not refresh the file, but QuickBuild does now! – Hayk Aug 24 '14 at 12:23
  • Did you configure Okular correctly? There are a couple of things to do to make it work nicely with Kile. One is in Settings > Editor where you should set the Editor to Kile and the Command to kile --line %l. The other is in Settings > General where you should ensure that Reload document on file change is checked. – cfr Aug 24 '14 at 18:09
  • @cfr: Thanks for this! I implemented your suggestion in Okular (The Editor was set to "Kate" previously, and the reload option was checked). What I have now is that PDFLatex command still does not refresh the PDF document, but the QuickBuild does. I now do not need to close the PDF file each time I run QuickBuild. Thanks! – Hayk Aug 25 '14 at 11:19
  • It works for me no matter how I compile but I'm not using Windows so perhaps there is a bug in Okular there. You might try searching the bugs database to see if anybody has reported it. Checking the 'reload' option should be enough. (It shouldn't matter what changes the file!) – cfr Aug 25 '14 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.