9

Precursor info: I'm on a Mac operating OSX 10.9.4, which I updated to months ago, before this problem started. I'm running LyX 2.1.

Just a few days ago I was using LyX with no problems. The next day, error messages started popping up such as:

"The selected document class Article (Standard Class) requires external files that are not available. The document class can still be used, but the document cannot be compiled until the following prerequisites are installed: article.cls"

and

"The module linguistics requires a package that is not available in your LaTeX installation, or a converter that you have not installed. LaTeX ouptut may not be possible. Missing prerequisites: covington.sty"

and

"The module natbib requires a package that is not available in your LaTeX installation, or a converter that you have not installed. LaTeX ouptut may not be possible. Missing prerequisites: natbib.sty"

I also cannot access any of my .bib documents. When I go to Tools > TeX Information, nothing is there (i.e. the LaTeX classes and styles, and BibTeX styles and databases sections are all empty).

I do, however, have what I believe is the correct directory available:

username/Library/texmf/bibtex/bib/.bib_docs_here username/Library/texmf/bibtex/bst/.bst_docs_here username/Library/texmf/tex/latex/packages_&_styles_here

Things I've tried:

  • Tools > Reconfigure, then quitting and restarting LyX.

  • I was on LyX 2.0 when this started. I erased LyX 2.0 from my computer and installed LyX 2.1. At Library/Application Support/LyX-2.1/ there is the same texmf file there, so it does look like the installation of LyX 2.1 correctly copied all of that information.

  • Full computer restart.

  • Removing and replacing all TeX related folders in Library.

I'd very much appreciate any diagnoses of what the problem might be and/or advice on how to solve it. Thank you.

  • Please try backing up your LyX home folder (find its location in Help > About) and then removing it. Do that without LyX running. Then start LyX. – scottkosty Aug 24 '14 at 21:02
11

I had the same problem and this is what resolved it for me:

  1. reinstall latest version MacTeX at: https://tug.org/mactex/
  2. install latest version of LyX: 2.1.1. (see: http://www.lyx.org/Download)
  3. Tools --> Reconfigure.
  4. Restart, check: Document --> Settings --> Document Classes: these should now be available.

I see from your question that you had already done most of these steps, so I am not sure if this will help you. Although, if you have had no success until now then following the exact steps (in this order) may be worth a try.

  • 1
    That did the trick. I had already downloaded LyX 2.1.1. So just installing the latest MacTeX version and reconfiguring worked fine. Many thanks! – lxgrdstdnt Sep 8 '14 at 21:23
  • 1
    Same for me, I updated MikTex (since I'm running Windows) but then forgot to do LyX Reconfigure. This fixed the issue. – gaborous Jan 19 '17 at 14:39
0

I had the same problem and this is what resolved it for me:

  1. reinstall latest version BasicTeX via homebrew
  2. Tools --> Reconfigure.
  3. Restart, check: Document --> Settings --> Document Classes: these should now be available.

If you still miss files, you can use tlmgr to install missing packages. For a good documentation on this and other things, have a look at alexandersavi.nl/blog/latex-on-mac-os-x/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.