1

I'm completely stuck with the syntax of the command options \node

Here is my code line:

\node [circle,fill=blue,scale=0.5,pin=60:$q_0$] at (9+90:15*4/30) {};

And it displays the same as if I had written pin=0:{60:$q_0$}

Where is my mistake ?

  • 2
    I do not get the same output from the two versions. What version of tikz do you have (use \listfiles at the beginning of your document to get this information) – Andrew Swann Aug 25 '14 at 9:41
  • Thanks for the help Andrew. version : 2.10 . the angle information is not token in account and is displayed and I can't figure it out. If you need the all code don't hesitate to ask but I am not sure it's very useful here. – rhum187 Aug 25 '14 at 9:59
  • 4
    Update to v 3.0.0 – skpblack Aug 25 '14 at 10:01
  • I'am afraid to do that. It seems to be a difficult task... – rhum187 Aug 25 '14 at 11:28
  • You should update you tex installation to include the new version. This is usually not hard. – Andrew Swann Aug 25 '14 at 13:15
1

Let me answer my own question because I think I have solved my problem. I met some difficulties to get there so if it can be used for other I'll explain in detail.

1/ I downloaded the PGF_3.0.0 package here.

2/ I unzipped it and save it on my desktop.

3/ I copy all the folders in the following directory : /Desktop/pgf_3.0.0.tds/tex/generic

4/ I paste (and replace) in the following directory : /usr/local/texlive/2013/texmf-dist/tex/generic

Then I though it was good and I manage the PGF update from 2.1.0 to 3.0.0 but I got the following error : I can't find filepgfutil-common-lists.tex`

5/ I follow those instructions and I did run this command export PATH=/usr/local/texlive/2013/bin/x86_64-darwin:~/bin:$PATH

6/ Then I run sudo mktexlsr command and I get the following answer from the terminal :

mktexlsr: Updating /usr/local/texlive/2013/../texmf-local/ls-R... 
mktexlsr: Updating /usr/local/texlive/2013/texmf-config/ls-R... 
mktexlsr: Updating /usr/local/texlive/2013/texmf-dist/ls-R... 
mktexlsr: Updating /usr/local/texlive/2013/texmf-var/ls-R... 
mktexlsr: Done.

(I did not follow the recommandation to add the 3 lines to the .bashrc because I was a bit lost...)

7/ Finally I opened TeXstudio and used a minimal document with the \pgfversioncommand and it displayed 3.0.0.... YES !!!

8/ I tested my code line :

\node [circle,fill=blue,scale=0.5,pin=60:$q_0$] at (9+90:15*4/30) {};

And I get the result I looked for. Thank you all !

mypic

  • With TL 2013 you should be able to do sudo tlmgr update pgf to update pgf to v.3.0. Or use TeX Live Utility, if that is available (it may only be part of MacTeX though). Updating manually like this shouldn't really be necessary. Alternatively, you could install TL2014. – Torbjørn T. Aug 26 '14 at 8:27
  • I tried to update like you that but, unfortunately, it did not work since the 2014 shows up... as least it's what I understood. And yes it was my last try, after that I'll install the 2014 (by the way : do not use chrome to download the 2014 package) – rhum187 Aug 26 '14 at 8:40
  • Hm, I thought it would work. Or perhaps I misremember, and PGF 3.0 didn't make it into TL 2013. Anyway, sorry about the noise. – Torbjørn T. Aug 26 '14 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.