0

I have the following problem: Some Tables have captions with references in them. This works, however, when I add a List of tables (and I'm using biblatex with refsection=chapter), this reference gets messed up in the List of tables (i.e., I get ['2] instead of 2.

Is there a magic trick? Or can I even "hide" all the used references from captions in the List of Tables?

    \documentclass{scrreprt}
\usepackage[refsection=chapter]{biblatex}
\usepackage[english]{babel}
\usepackage[T1]{fontenc}
\usepackage[ansinew]{inputenc}
\begin{filecontents}{biblio.bib}
@book{goossens93,
    author = "Michel Goossens and Frank Mittlebach and Alexander Samarin",
    title = "The Latex Companion A",
    year = "1993",
    publisher = "Addison-Wesley",
    address = "Reading, Massachusetts"

}

@article{greenwade93, 
    author = "George D. Greenwade",
    title = "The {C}omprehensive {T}ex {A}rchive {N}etwork ({CTAN})",
    year = "1993",
    journal = "TUGBoat",
    volume = "14",
    number = "3",
    pages = "342--351",
           url=" www.ctan.org"
}

\end{filecontents}

\addbibresource{biblio.bib}

\begin{document}
\listoftables
\chapter{Test Chapter One}
\cite{goossens93}
\printbibliography[heading=subbibliography]

\chapter{Test Chapter Two}

\begin{table}
\caption{Tabelle mit \cite{goossens93}}
\centering
\begin{tabular}{lll}
    \hline
    \textbf{linke Spalte} & \textbf{mittlere Spalte} & \textbf{rechte Spalte} \\
    \hline
    i & ii & iii \\
    \hline
\end{tabular}

\end{table}

\printbibliography[heading=subbibliography]

\end{document}

enter image description here

enter image description here

  • Welcome to TeX.SX!. I'm not sure what you mean by 'hide' here - your caption makes no sense without the reference.. \caption[Caption for List of Tables]{Tabelle mit \cite{goossens93}} would allow setting a different caption for the list of tables. – greyshade Aug 26 '14 at 13:42
  • Hey. Thanks for the quick reply! That trick with [] could do the job for 'hiding' the reference in the list. But I still don't see the reason why it gives me ['2] in the first place... – screeny2 Aug 26 '14 at 13:47
  • Added the screenshots. I did a new install this week....(using miktex for windows) – screeny2 Aug 26 '14 at 14:20
  • Mhhhh, I think this has to do with the use of refsections. When you use \cite in the table, the cite is called in refsection 2, but when the caption is copied to the list of tables, the cite (issued and thought to have been originated and confined to section 2) suddenly appears in refsection 0 - and that naturally causes havoc (especially in the auxiliary files and when trying to read those). The output ['1] that you get is just LaTeX trying to make the best of a bad job, i.e. trying to get a reasonable output from a messed-up input. – moewe Aug 26 '14 at 15:51
  • So you could get rid of refsection (probably not what you want), or - as greyshade suggested - use the optional argument to caption to specify a shorter caption for the list of tables. (It would be weird to have the reference visible in the list of tables anyway if you have a per-chapter bibliography, as it just adds to the confusion on where to look up the reference. Normally, a reference in a table of ... / list of ... is not really of lot of use anway.) – moewe Aug 26 '14 at 15:58