1

This question already has an answer here:

I am writing some thesis in Latex and I use some template, which I placed at the bottom. I have got problem with references. I would like to put the links to references in order of appearance, not in alphabetical order. The first link to reference should have [1] the second [2]. Now I have got situation that reference is ordered in alphabetical order, e.g. the first link to reference is not [1], but e.g. [4], because of fact that this follows from the alphabetical order.

Below a simple visualization:

Now:
text text[3] text text[1] text text[2]
reference:
[1]Adam Simson
[2]David Johnson
[3]Jessy Hoffman

I would like to have:

text text[1] text text[2] text text[3]
reference:
[1]Jessy Hoffman
[2]Adam Simson
[3]David Johnson

This is the template, which I am using:

https://drive.google.com/file/d/0BwyOySLlDTB_a3R5aFZQNzVFRG8/edit?usp=sharing

In folder Classes there is a file "PhDThesisPSnPDF.cls" and there is something like is printed below. I tried to modify it, change style to "plain", but it didn't help. How can I solve it? Very thanks for help.

% ******************************* Bibliography *********************************
\ifPHD@authoryear
\ifPHD@biblatex
\RequirePackage[backend=biber, style=authoryear, citestyle=alphabetic, sorting=nty, natbib=true]{biblatex}
\setBiBLaTeXtrue
\else
\RequirePackage[round, sort, numbers, authoryear]{natbib} %author year
\fi
\setBibtrue
\else
     \ifPHD@numbered
     \ifPHD@biblatex
     \RequirePackage[backend=biber, style=numeric-comp, citestyle=numeric, sorting=none, natbib=true]{biblatex}
     \setBiBLaTeXtrue
     \else
     \RequirePackage[numbers,sort&compress]{natbib} % numbered citation
     \fi
     \setBibtrue
     \else
         \ifPHD@custombib
         \setBibfalse
         \ifPHD@biblatex
             \setBiBLaTeXtrue
         \fi
         \else
             \ifPHD@biblatex
                 \RequirePackage[backend=biber, style=numeric-comp, citestyle=numeric, sorting=none, natbib=true]{biblatex}
                 \setBiBLaTeXtrue
             \else
                 \RequirePackage[numbers,sort&compress]{natbib} % Default - numbered
             \fi
         \setBibtrue
     \ClassWarning{PhDThesisPSnPDF}{No bibliography style was specified.
Default numbered style is used. If you would like to use a different style, use
`authoryear' or `numbered' in the options in documentclass or use `custombib`
and define the natbib package or biblatex package with required style in the Preamble.tex file}
         \fi
     \fi
\fi

marked as duplicate by Tobi, user13907, Svend Tveskæg, user31729, Guido Aug 26 '14 at 19:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Use an unsorted style, e.g. unsrt (with plain bibtex) or unsrtnat (with natbib). For biblatex load the package with sorting=none or do \ExecuteBibliographyOptions{sorting=none} in your preamble. – Henri Menke Aug 26 '14 at 18:29
  • I saw this posts, but it didn't help me. – Dawid Aug 26 '14 at 18:44

Browse other questions tagged or ask your own question.