5

So, I am TeXStudio and R on Windows 8 and have configured with knitr as follows:

"C:\Program Files\R\R-3.0.3\bin\Rscript" -e "library(knitr, lib.loc='C:/Users/User/Documents/R/win-library/3.0'); knit2pdf('%.Rnw')"| -synctex=1 -interaction=nonstopmode %.tex.

The other options are at their defaults.

But I do not know any means of syncing ('Go to source')from the pdf viewer to the .Rnw file. I run into the problem that it calls the .tex file instead. Is there any way to fix this from the build options?

Thanks.

3

This results from the combination of Synctex and the build chain is rnw -> tex -> pdf. Synctex is originally designed to provide a connection between the tex file and the pdf. It does not know anything about the rnw.

see also: https://tex.stackexchange.com/a/210553/24770

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.