2

I have checked the whole forum for finding solution to this problem.

Problem: I have added some footnotes to my LaTeX template. All footnotes work fine except this one. This is how it appears enter image description here

Here is the minimal working example.

\documentclass{fcs}
\usepackage{bm}

\volumn{ }
\doi{ }
\articletype{REVIEW~ARTICLE}
\copynote{{\copyright} Higher Education Press and Springer-Verlag Berlin Heidelberg 2012}
\ratime{Received month dd, yyyy; accepted month dd, yyyy}
\email{$\times\times\times\times@\times\times\times.\times\times\times$}
%% Title
\title{$\bm{Frontiers~ of~ Computer~ Science}$\\[2mm] Instruction for authors}
%% Authors
\author{Firstname LASTNAME \xff $^{1,2}$}
%% Addresses of authors
\address{{1\quad Higher Education Press, Beijing 100029, China}\\
{2\quad Acadcmic Journal Division, Beijing 100029, China}}

%% Running head
\markboth{Front. Comput. Sci.}{Firstname LASTNAME: please insert running head here}

\begin{document}
\maketitle
\setcounter{page}{1}
\setlength{\baselineskip}{14pt}

\begin{abstract}
 A short abstract of up to 300 words written in one paragraph
\end{abstract}

\Keywords{Up to 8 words separated by commas.}

\section{Introduction}

\noindent Frontiers of Computer Science is an international
peer-reviewed academic journal sponsored by the Ministry of
Education of China. The journal is jointly published by Higher
Education Press of China and Springer on a bimonthly basis in
English. Online versions are available through both
http://www.springerlink.com/content/11704 and
http://journal.hep.com.cn/fcs.
% here is my line
For instance, \textit{@ActionID}\footnote{http://bits.netbeans.org/dev/javadoc/org-   openide-awt/org/openide/awt/ActionID.html, verified 24-07-14} taken from the NetBeans  FAQ\footnote{http://wiki.netbeans.org/DevFaqActionAddJavaPackage,verified 24-07-14} deals with the retention (how long annotations are to be retained in a system) and target of a code.

\end{document}

It is clearly seen that the first footnote doesn't appear properly while the second one appears almost perfect.

  • it looks like you are not using \url, which is generally pretty good at breaking urls at places other than existing hyphens. see URL linebreak in footnote for some possibly useful information. – barbara beeton Aug 27 '14 at 16:10
  • @barbara beeton I tried the solution you suggested but it didn't work. – Skipper07 Aug 27 '14 at 16:22
  • @Skipper07: Any solutions friend is not necessary. – user56567 Aug 27 '14 at 16:22
  • @cornelius Ok I will keep it in mind, next time. – Skipper07 Aug 27 '14 at 16:30
2

The problem comes from the two-column mode: the url command can cut an address at specific characters (mainly at \, but the hyphens option allows hyphen characters.

One can use the macro defined in the documentation, that lets you use the exclamation mark as indicating an allowed line break. However it is not required, if the url style is set to same (same font as the main roman font of the document).

So here is a solution:

\documentclass{fcs}
\usepackage{bm}

\usepackage[hyphens, allowmove]{url} %
\makeatletter \g@addto@macro\UrlSpecials{\do\!{\newline}}\makeatother
\urlstyle{same}

\volumn{ }
\doi{ }
\articletype{REVIEW~ARTICLE}
\copynote{{\copyright} Higher Education Press and Springer-Verlag Berlin Heidelberg 2012}
\ratime{Received month dd, yyyy; accepted month dd, yyyy}
\email{$\times\times\times\times@\times\times\times.\times\times\times$}
%% Title
\title{$\bm{Frontiers~ of~ Computer~ Science}$\\[2mm] Instruction for authors}
%% Authors
\author{Firstname LASTNAME \xff $^{1,2}$}
%% Addresses of authors
\address{{1\quad Higher Education Press, Beijing 100029, China}\\
{2\quad Academic Journal Division, Beijing 100029, China}}

%% Running head
\markboth{Front. Comput. Sci.}{Firstname LASTNAME: please insert running head here}

\begin{document}
\maketitle
\setcounter{page}{1}
\setlength{\baselineskip}{14pt}

\begin{abstract}
 A short abstract of up to 300 words written in one paragraph
\end{abstract}

\Keywords{Up to 8 words separated by commas.}

\section{Introduction}

\noindent Frontiers of Computer Science is an international
peer-reviewed academic journal sponsored by the Ministry of
Education of China. The journal is jointly published by Higher
Education Press of China and Springer on a bimonthly basis in
English. Online versions are available through both
http://www.springerlink.com/content/11704 and
http://journal.hep.com.cn/fcs.
% here is my line\url{http://bits.netbeans.org/dev/javadoc/org- openide-awt/org/openide/awt/ActionID.html}
For instance, \textit{@ActionID}\footnote{\url{http://bits.netbeans.org/dev/javadoc/org-openide-awt/org/openide/awt/ActionID.html}, verified 24-07-14} taken from the NetBeans FAQ\footnote{\url{http://wiki.netbeans.org/DevFaqActionAddJavaPackage}, verified 24-07-14} deals with the retention (how long annotations are to be retained in a system) and target of a code.

\end{document}

enter image description here

  • Thanks the solution. It works for most of the strings but some longer urls disturbs the alignment. Also, the font for URL doesn't seem fit for the template...I hope it would be accepted. – Skipper07 Aug 28 '14 at 2:54
  • @Skipper07: I think you'll have to break by hand, and it will not be really justified. Another solution would have been to use \RaggedRight (from the ragged2e package). As for the font it is the default for the url package, but that may be changed. I'll see how to fit the template. – Bernard Aug 28 '14 at 7:55
  • @Skipper07: Does the font for urls have to be simply the main roman font of the document? – Bernard Aug 28 '14 at 8:01
  • @Skipper07: The style option same seems to solve your problem. – Bernard Aug 28 '14 at 8:13
  • @Beranrd How to use the style option same? – Skipper07 Aug 28 '14 at 9:29
1

As Barbara Benton mentioned in her comments, just use url package. It (using article document class -- I'm not familiar with fcd) gives expected results. enter image description here My MWE:

\documentclass{article}
    \usepackage{url}
        \begin{document}

    \section{Introduction}
Frontiers of Computer Science is an international peer-reviewed academic journal sponsored by the Ministry of Education of China. The journal is jointly published by Higher Education Press of China and Springer on a bimonthly basis in English. Online versions are available through both
\url{http://www.springerlink.com/content/11704} and
\url{http://journal.hep.com.cn/fcs}.
% here is my line
For instance, \textit{@ActionID}%
    \footnote{\url{http://bits.netbeans.org/dev/javadoc/org-openide-awt/org/openide/awt/ActionID.html},
verified 24-07-14} taken from the NetBeans  FAQ%
    \footnote{\url{http://wiki.netbeans.org/DevFaqActionAddJavaPackage}, verified 24-07-14}
deals with the retention (how long annotations are to be retained in a system) and target of a code.
    \end{document}
  • no difference...I tried it before but result is same. – Skipper07 Aug 27 '14 at 17:05
  • @Skipper07: Maybe the problem comes from some incompatibility with the class file you use. What is fcs.cls? – Bernard Aug 27 '14 at 17:42
  • @Bernard Yes it could be possible ...FCS is a cls file for one of the journals. If it is submitted with these problems it will be rejected. Therefore, I am looking for a solution here. – Skipper07 Aug 27 '14 at 18:39
  • Where can this file be found, and which journal, just to check? – Bernard Aug 27 '14 at 19:03
  • @Bernard You can download the latex template at this url [journal.hep.com.cn/fcs/EN/column/column11258.shtml] – Skipper07 Aug 27 '14 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.