2

I try to insert some explanatory text into numbered list as below:

1. Number 1
    explanation of Number 1
2. Number 2

But when I do it in LyX, I try to change the "explanation" line as "Standard", then the second number will change to 1 (I wish it's 2).

So the actual result is:

1. Number 1
    explanation of Number 1
1. Number 2

What's the right way to do such document?

Update:

Maybe issue caused by beamer. I am using beamer in lyx.

#LyX 2.1 created this file. For more info see http://www.lyx.org/
\lyxformat 474
\begin_document
\begin_header
\textclass beamer
\use_default_options true
\maintain_unincluded_children false
\language english
\language_package default
\inputencoding auto
\fontencoding global
\font_roman default
\font_sans default
\font_typewriter default
\font_math auto
\font_default_family default
\use_non_tex_fonts false
\font_sc false
\font_osf false
\font_sf_scale 100
\font_tt_scale 100
\graphics default
\default_output_format default
\output_sync 0
\bibtex_command default
\index_command default
\paperfontsize default
\spacing single
\use_hyperref false
\papersize default
\use_geometry true
\use_package amsmath 1
\use_package amssymb 1
\use_package cancel 1
\use_package esint 1
\use_package mathdots 1
\use_package mathtools 1
\use_package mhchem 1
\use_package stackrel 1
\use_package stmaryrd 1
\use_package undertilde 1
\cite_engine basic
\cite_engine_type default
\biblio_style plain
\use_bibtopic false
\use_indices false
\paperorientation portrait
\suppress_date false
\justification true
\use_refstyle 1
\index Index
\shortcut idx
\color #008000
\end_index
\secnumdepth 3
\tocdepth 3
\paragraph_separation indent
\paragraph_indentation default
\quotes_language english
\papercolumns 1
\papersides 1
\paperpagestyle default
\tracking_changes false
\output_changes false
\html_math_output 0
\html_css_as_file 0
\html_be_strict false
\end_header

\begin_body

\begin_layout FragileFrame
\begin_inset Argument 4
status open

\begin_layout Plain Layout
Title
\end_layout

\end_inset


\end_layout

\begin_deeper
\begin_layout Enumerate
item 1
\end_layout

\begin_layout Enumerate
item 2
\end_layout

\begin_layout Standard
what's item 2.
\end_layout

\begin_layout Enumerate
item 3
\end_layout

\end_deeper
\begin_layout FragileFrame

\end_layout

\end_body
\end_document

You can try this exam, the module has been grey out so can not add at all.

  • 1
    Take a look at Help > User Guide and search for "Resumed Enumeration" (it is the title of a section, 3.3.7.2 currently). Also, is there a reason you used the latex3 tag? – scottkosty Aug 29 '14 at 22:50
  • The document says "To resume an enumeration, use the style Enumerate-Resume. ", but I still not figure how to do it! – Beatlej Aug 30 '14 at 1:30
  • Sorry, I should have told you to read starting at 3.3.7. You need to add the "Customisable Lists (enumitem)" module. Go to Document > Settings > Modules and add it. Then you will have access to the Enumerate-Resume style. – scottkosty Aug 30 '14 at 1:42
2

It depends on what you want. If there is a lot of text between the two points, and the enumerate is somehow "within the text" (if you see what I mean), then you should enumerate-resume as scottkosty says. But if you want the text between the bullet points to be "within the enumerate", then this is supported in LyX as follows, without the need for extra modules or tricks.

Do as you did before:

1. Number 1.
Paragraph after number 1.
1. Number 2.

This should show as above in both LyX and the PDF output. Now put your cursor into the paragraph after number 1 and press tab. Now you will see this:

1. Number 1.
   Paragraph after number 1.
2. Number 2.

It will look like this in both LyX and the PDF output.

  • Got it. that's perfect answer to me. – Beatlej Aug 31 '14 at 23:48
  • @Beatlej If this is the answer that you wanted, perhaps you could mark it as the accepted answer? – Jim Oldfield Sep 1 '14 at 14:30
2

You will need the customizable lists (enumitem) module. Once you add that (in Document > Settings> Modules), to resume an enumeration, go to the dropdown list in the upper-right (that probably says either "enumerate" or "standard") and just "Enumerate-Resume"

Here is an example .lyx file (requires LyX 2.1 to open):

#LyX 2.2 created this file. For more info see http://www.lyx.org/
\lyxformat 474
\begin_document
\begin_header
\textclass article
\use_default_options true
\begin_modules
enumitem
\end_modules
\maintain_unincluded_children false
\language english
\language_package default
\inputencoding auto
\fontencoding global
\font_roman default
\font_sans default
\font_typewriter default
\font_math auto
\font_default_family default
\use_non_tex_fonts false
\font_sc false
\font_osf false
\font_sf_scale 100
\font_tt_scale 100
\graphics default
\default_output_format default
\output_sync 0
\bibtex_command default
\index_command default
\paperfontsize default
\spacing single
\use_hyperref false
\papersize default
\use_geometry false
\use_package amsmath 1
\use_package amssymb 1
\use_package cancel 1
\use_package esint 1
\use_package mathdots 1
\use_package mhchem 1
\use_package stackrel 1
\use_package stmaryrd 1
\use_package undertilde 1
\cite_engine basic
\cite_engine_type default
\biblio_style plain
\use_bibtopic false
\use_indices false
\paperorientation portrait
\suppress_date false
\justification true
\use_refstyle 1
\index Index
\shortcut idx
\color #008000
\end_index
\secnumdepth 3
\tocdepth 3
\paragraph_separation indent
\paragraph_indentation default
\quotes_language english
\papercolumns 1
\papersides 1
\paperpagestyle default
\tracking_changes false
\output_changes false
\html_math_output 0
\html_css_as_file 0
\html_be_strict false
\end_header

\begin_body

\begin_layout Enumerate
Number 1
\end_layout

\begin_layout Standard
explanation of number 1
\end_layout

\begin_layout Enumerate-Resume
Number 2
\end_layout

\end_body
\end_document

output:

enter image description here

For more information, see the user guide, section 3.3.7.

EDIT: This will not work with beamer because beamer does not work with enumitem (see lib/layouts/beamer.layout). As explained at http://www.lyx.org/trac/ticket/7047,

enumitem is not compatible with beamer, since beamer extensively redefines all lists (for the overlays etc.).

  • I have download one module and put it at ~/.lyx/layouts/enumitem.module,then I reconfigure Lyx and restart. but when I try to select the module, the "Add" button has been grey out. what's wrong with me? – Beatlej Aug 30 '14 at 1:52
  • You should not have to download the module. It wasn't in the list when you went to Document > Settings > Modules? What version of LyX are you using? Are all the modules greyed out or just that one? The only reason I can think of is that your document is read only (e.g. you were reading the User Guide). Otherwise, please post a minimal example. Did the example I post work for you? – scottkosty Aug 30 '14 at 2:31
  • Please check my update in question. – Beatlej Aug 30 '14 at 3:04
  • @Beatlej I see your example, but you did not answer all of my questions... – scottkosty Aug 30 '14 at 3:09
  • 1
    @Beatlej Or use Jim's answer above. – scottkosty Sep 1 '14 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.