2

My machine was powered down after it was frozen, but I still managed to save the current Latex file. When I turned the machine back on and tried to import the file in texmaker , I was given this message:

It seems taht this file cannot be correctly decoded with the default encoding setting (UTF-8)

Moreover, I looked at the file's charset using the file -bi name_of_file in my command line, and I got that the file's charset is binary. I tried the iconv utility in linux to try convert it to utf-8 charset but it didn't work as the binary charset is not supported by iconv. Is there any way I can save this file? I really need its contents.

Thanks in advance.

closed as unclear what you're asking by David Carlisle, Martin Schröder, user31729, R. Schumacher, user13907 Sep 7 '15 at 22:31

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try to edit or copy & paste in gedit, and then sava copy with "Save as" taking care of the options (encoding and the type of end of line). Check that is not a corrupted file (no lost text, no unexpected characters). In the worse case, testdisk could be useful. – Fran Aug 30 '14 at 23:07
  • Just open the file in a editor that opens binary file. In windows, I would have used notepad++. Then it is just to copy and paste out the readable content, search for rubbish and replace with what should have been there. Of course, if the file is toatally destroyed (just full of strange charackters, @@@@@@&&&---'///" etc), nothing will help other than a fresh backup. – Sveinung Aug 30 '14 at 23:09
  • @Fran You were faster than me! – Sveinung Aug 30 '14 at 23:10
  • Are there any news to report? – Johannes_B Jun 14 '15 at 20:43