I'm trying to use the \citep command in Latex and my document class is elsarticle. The problem is that it displays numbers not authoryear citations in the text which is what I'm looking for. Here are related parts of my code:






And I'm obviously using the \citep command like this:

    I once read \citep{edelman1993magnetic}

And my .bib file looks like this:

title={Regional brain activation changes and abnormal functional connectivity of the         ventrolateral prefrontal cortex during working memory processing in adults with attention-deficit/hyperactivity disorder},
author={Wolf, Robert C and Plichta, Michael M and Sambataro, Fabio and Fallgatter,     Andreas J and Jacob, Christian and Lesch, Klaus-Peter and Herrmann, Martin J and     Sch{\"o}nfeldt-Lecuona, Carlos and Connemann, Bernhard J and Gr{\"o}n, Georg and others},
journal={Human brain mapping},
publisher={Wiley Online Library}

The result looks like:

I once read[1]

I'm looking for a result like this:

I once read(wolf., 2009)

Elsevier is actually looking for:

Text: All citations in the text should refer to:

  1. Single author: the author's name (without initials, unless there is ambiguity) and the year of publication;

  2. Two authors: both authors' names and the year of publication;

  3. Three or more authors: first author's name followed by 'et al.' and the year of publication.

Thanks in advance


1 Answer 1


The elsarticle class loads natbib by default so you don't need to load natbib via \usepackage. By default it loads it with a numerical scheme, but the class option authoryear will change that. The matching bibliography style is then elsarticle-harv:

Sample output



I once read \citep{wolf2009regional}.



You must log in to answer this question.