5

I currently print my references after the end of each chapter, using:

\usepackage[backend=biber,
    bibencoding=utf8,
    refsection=chapter,
    style=numeric, 
    firstinits=true,
    isbn=false,
    doi=true,
    url=false,
    clearlang=true
]{biblatex}

and

\printbibliography[heading=subbibliography]

at the end of each chapter.

I would like to have also a chapter at the end of the book with all cited references. How could I do ?

  • Using the numeric style that is a very dangerous idea indeed. There will be a [1] in chapter 1 and a [1] in chapter 2, but they might not necessarily be the same work. What is [1] supposed to be in the cumulative bibliography? – moewe Sep 3 '14 at 15:25
7

We can use refsegment instead of refsection (read about refsection and refsegment in the biblatex documentation §3.6.5 Bibliography Sections & §3.6.6 Bibliography Segments, pp. 78-79).

Instead of refsection=chapter we pass refsegment=chapter to biblatex, we also issue defernumbers=true (you can find out more about defernumbers on p. 53 of the doc).

We then have to specify the segment in the per-chapter bib manually, but this can be automated with \therefsegment, so the chapter-bibliographies are

\printbibliography[segment=\therefsegment,heading=subbibliography]

The full end-document bib is created by

\printbibliography

MWE

\documentclass{book}
\usepackage[backend=biber,
    bibencoding=utf8,
    refsegment=chapter,
    style=numeric, 
    firstinits=true,
    isbn=false,
    doi=true,
    url=false,
    clearlang=true,
    defernumbers=true,
]{biblatex}

\addbibresource{biblatex-examples.bib}

\begin{document}
\tableofcontents

\chapter{Ch 1}
A citation \cite{wilde}.
\printbibliography[segment=\therefsegment,heading=subbibliography]

\chapter{Ch 2}
And another one \cite{cicero}.
\printbibliography[segment=\therefsegment,heading=subbibliography]

\printbibliography
\end{document}

enter image description here

  • hi. Thanks, this almost works. In my thesis, defernumbers messes up the numerotation. It starts at 57 for some reason... If i remove it, its seems ok. I don't get the documentation for this option. – Napseis Sep 3 '14 at 22:06
  • @Napseis I used defernumbers to get [1] in the first chapter and [2] in the second. Otherwise it would have been [2] in the first and [1] in the second. As far as I understand defernumbers makes sure an entry gets a number the first time it is printed in a bibliography. Note that with refsection the numbering was local and confined to one refsection (i.e. a chapter) while refsection applies global numbering. – moewe Sep 4 '14 at 6:02
  • hum, I understand the same thing from the doc. And this is desirable, in fact, but not if it starts from some random number. Thanks anyway. – Napseis Sep 4 '14 at 9:36
  • @Napseis I'm only speculating here, but that may be because of the sorting in the bibliography, maybe a sorting=none to the global options might help there. But if it works for you without defernumbers and you notice no adverse effects, I guess it's not absolutely necessary to investigate further. If you are interested in a solution though (I know, I am), you could ask a new question with a short MWE that shows the issue (maybe not with 57 entries, probably better 3, 4 or so). – moewe Sep 4 '14 at 14:40
  • according to here, tex.stackexchange.com/questions/163611/… this is a bug. I don't have Texlive 2014 in Fedora 20,so I will wait.. – Napseis Sep 18 '14 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.