It's possible to run htlatex in silencemode like pdflatex.

pdflatex --draftmode --interaction=nonstopmode foo.tex > tmp.txt

I have found only nonstopmode/batchmode in htlatex.

htlatex source.tex "3" "" "" "--interaction==nonstopmode". Any ideas?

  • htlatex ... > /dev/null on a Unix system.
    – egreg
    Sep 4, 2014 at 7:28
  • I have used htlatex ... > c:\test.html on a Windows system and it's working fine. Could you answer my question so that i will accept your answer for future viewers..
    – Balaji
    Sep 4, 2014 at 7:37
  • Sorry, but I'm no expert of Windows. According to this (old) answer by Jon Skeet, you can use > NUL on Windows system.
    – egreg
    Sep 4, 2014 at 8:01

1 Answer 1


Output redirection is obtained by adding > <file> to the command line.


htlatex "other options..." "--interaction=nonstopmode" > filename

will record the session in filename. This works on Unix shells and also with the Windows command line interface.

If no record is needed, use

> /dev/null

instead of > filename on Unix systems and


on Windows (see https://stackoverflow.com/questions/313111/dev-null-in-windows). Note that filename is an arbitrary file name possibly including a path, but of course the user should be able to write in the pointed at directory.

Depending on the system setup, > filename might refuse to execute, if the file already exists. With a Bash shell, use >| filename for overriding the noclobber option; other command shell may have different workarounds.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .