0

My main tex file is set for double space, but my bibliography must be different. Each item is single space (line spacing, intra item), separated by a double space (paragraph spacing, inter item). All this I was able to do.

But in the process the space between bibliography title and first item was reduced from triple to a double space. Here is what I did to fix the spacing for bibliography items, but it messed with the triple-spaced title making it double space.

    \documentclass{report}

    \RequirePackage[backend=biber,sorting=nyt]{biblatex}

    \singlespace
    \setlength\bibitemsep{3.0\itemsep}

    \printbibliography

    \end{document} 

Here is the double space title I have (wrong), represented in red:

enter image description here

Here is the triple space title I need (right), represented in red:

enter image description here

Here is the bibliography environment in the cls file.

% Bibliography
\renewenvironment{thebibliography}[1]
     {\chapter*{\bibname}%
      \@mkboth{\MakeUppercase\bibname}{\MakeUppercase\bibname}%
      \addcontentsline{toc}{chapter}{\bibname}%
      \singlespacing
      \list{}%
           {\itemindent -0.5in
            \leftmargin 0.5in
           }%
      \sloppy
      \clubpenalty4000
      \@clubpenalty \clubpenalty
      \widowpenalty4000%
      \sfcode`\.\@m}
     {\def\@noitemerr
       {\@latex@warning{Empty `thebibliography' environment}}%
      \endlist}

And here the heading section in the cls:

% Headings
\RequirePackage[overload]{textcase}
\setcounter{secnumdepth}{0}% how many sectioning levels to assign numbers to
\setcounter{tocdepth}{7}


\def\@makechapterhead#1{%
  \vspace*{0.544in}%
  {\parindent \z@ \raggedright 
  \normalfont
    \ifnum \c@secnumdepth >\m@ne
        \centering\MakeUppercase{\@chapapp}\space \thechapter
        \par\nobreak
        \vskip 15pt%
    \fi
    \interlinepenalty\@M
    \csname @flushglue\endcsname=0pt plus 0.2in
    \centering
    \hyphenpenalty=10000
    \parshape=5 0.625in 4.75in 0.875in 4.25in 1.125in 3.75in 1.375in 3.25in 1.625in 2.75in
    \spaceskip=\fontdimen2\font
    \MakeUppercase{#1}\par\nobreak
    \vskip 15pt%
  }}
\def\@makeschapterhead#1{%
  \vspace*{0.544in}%
  {\parindent \z@ \raggedright
    \normalfont
    \interlinepenalty\@M
    \csname @flushglue\endcsname=0pt plus 0.05\linewidth
    \centering
    \hyphenpenalty=10000
    \parshape=5 0.625in 4.75in 0.875in 4.25in 1.125in 3.75in 1.375in 3.25in 1.625in 2.75in
    \MakeUppercase{#1}\par\nobreak
    \vskip 15pt%
  }}

What could be done to preserve triple space for Bibliography title? I have no idea of the culprit overriding it.

  • Could we have a minimal working example? I suppose you use biblatex since you have a \printbibliography command? – Bernard Sep 4 '14 at 22:49
  • Here is a temporary link to the file [writelatex.com/1407938hhkbvw#/3503745/] – Nhaps Sep 5 '14 at 0:33
  • Yes, I use biblatex – Nhaps Sep 5 '14 at 4:55
  • I tried your code with a .bibfile of mine. However I had to replace the autemplate document class with report, and it had the normal behaviour: the spacing between biblio title and first item is the spacing between any chapter title and chapter body in single space, which incidentally is more than what you call ‘triple space’ (is it 3 \baselineskip?). Could you explain more details of what you want? – Bernard Sep 5 '14 at 8:25
  • By triple space I mean 3 \baselineskip, yes. As I said earlier the document is double space and by using commands to turn the biliography entries in single space this also changes the title space before first item. So the 3 baseline changes to 2, how to maintain 3? Which piece of coding to protect it in \renewenvironment above? Or another way? – Nhaps Sep 5 '14 at 11:19
3

There are a couple of tricky things going on here.

  1. It looks like the renewed thebibliography environment has no effect when you're using biblatex.

  2. When you switch to single spacing with the \singlespacing command, it inserts a \vskip \baselineskip to make the transition to single spacing (see the definition here).

If you define your own chapter heading, reverse the \vskip and use the heading=none option for biblatex, that seems to do it:

\chapter*{Bibliography}

\singlespace
\vskip -\baselineskip
\setlength\bibitemsep{3.0\itemsep}
\printbibliography[heading=none]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.