7

I am writing my thesis using \documentclass{report} so that I will have chapters. I have used

\renewcommand{\thepage}{\roman{page}}% Roman numerals for page counter

at the beginning in order to use roman numbering before the first chapter begins. Then I have used

\renewcommand{\thepage}{\arabic{page}}% Arabic numerals for page counter
\setcounter{page}{1}% Start page number with 1

just before the first chapter begins in order to use arabic numbering for the rest of the thesis. However, I noticed that the last few pages, which include the last page of my list of tables and my bibliography, use roman numbering. The start and end of my .tex file looks like this...

Start:

\documentclass[a4paper,11pt]{report}

\usepackage[latin1]{inputenc}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{graphicx,color}
\usepackage{epsfig}
\usepackage{epstopdf}
\usepackage{dcolumn}
\usepackage{bm}
\usepackage{mathrsfs}
\usepackage{dsfont}
\usepackage{setspace}
\usepackage[toc,page]{appendix}
\usepackage[
asymmetric,
lmargin=4cm,
rmargin=2cm,
tmargin=2cm,
bmargin=2cm
]{geometry}

%user defined terms
\newcommand{\nspace}{\!\!\!\!\!\!\!}  % used to take out space between sum and integral symbols
\newcommand{\avg}[1]{\left< #1 \right>} % for average

\renewcommand{\thepage}{\roman{page}}% Roman numerals for page counter
\setcounter{page}{1}% Start page number with 1
%opening
\title{}
\date{}

\begin{document}

\maketitle

End:

\listoffigures

\clearpage
\listoftables

\end{normalsize}

\clearpage
\bibliographystyle{ieeetr}
\bibliography{Thesis}

\end{document}

I have tried changing the end to:

\listoffigures

\clearpage
\renewcommand{\thepage}{\arabic{page}}% Arabic page numbers
\listoftables

\end{normalsize}

\clearpage
\bibliographystyle{ieeetr}
\bibliography{Thesis}

\end{document}

to force the page numbering to arabic, but this doesn't work. I've also tried

\listoffigures
\clearpage
\renewcommand{\thepage}{\arabic{page}}% Arabic page numbers
\listoftables

\end{normalsize}
\clearpage
\renewcommand{\thepage}{\arabic{page}}% Arabic page numbers
\bibliographystyle{ieeetr}
\bibliography{Thesis}

\end{document}

This returns the bibliography pages to arabic numbering, but the page before, with the last part of the list of tables on it, still has a roman numeral.

What can I do to make ALL pages from chapter 1 onward use arabic numbering?

  • 2
    Welcome to TeX.SX! Please make your code compilable (if possible), or at least complete it with \documentclass{...}, the required \usepackage's, \begin{document}, and \end{document}. That may seem tedious to you, but think of the extra work it represents for TeX.SX users willing to give you a hand. Help them help you: remove that one hurdle between you and a solution to your problem. \pagenumbering{arabic} and \pagenumbering{roman} do the job just fine. – Johannes_B Sep 5 '14 at 18:12
  • 1
    \normalsize is a command - not an environment. – cfr Sep 5 '14 at 18:13
  • 1
    @DavidCarlisle I thought it was considered better not to do that, though, even though I know that is so? – cfr Sep 5 '14 at 19:37
  • 1
    What would really be helpful is a complete example. One copy, one paste, one compile and go. Please merge your snippets to a minimal working example (MWE) that does show the issue and makes it reproducable for us. – Johannes_B Sep 6 '14 at 14:43
3

In virtually all document page numbering systems I'm familiar with that use roman numerals for the front matter and arabic numerals for the main matter (starting with the first "real" chapter header), the arabic numbers start at 1 after the switch. LaTeX provides an easy command to switch the page numbering system and restart page numbering at 1:

\pagenumbering{<numbering system>}

Here <numbering system> may be arabic, roman, Roman, alph, and Alph. (I trust you can figure out what the "numbers" look like in each of these systems.) In your case, in order to switch to arabic numerals and restart page numbering at 1, you should type

\pagenumbering{arabic} 

Do keep using the report document class.

An outline of your document, starting with \begin{document}, thus might be:

\begin{document}
\pagenumbering{roman} % NOT "\renewcommand{\thepage}{\roman{page}} \setcounter{page}{1}
\maketitle
\tableofcontents
\listoffigures
\listoftables

\clearpage
\pagenumbering{arabic} % NOT "\renewcommand{\thepage}{\arabic{page}} \setcounter{page}{1}
\chapter{...}
...
\bibliography{...}
\end{document}
  • 1
    Nice answer, I take this opportunity to ask a question about it. What if besides having to renumber Roman to Arabic I have to reset the counter of pages to 1 at the start of chapter one in a class report or any other different than book? – Aradnix Sep 6 '14 at 17:51
  • 1
    @Aradnix - thanks! The \pagenumbering macro, among other things, resets the page number to 0 automatically. That's why it's better to use it than to execute separate macros to reset the page number to 0 and to change the appearance of the page numbers (from roman to arabic, say). – Mico Sep 6 '14 at 17:57
  • Is nice to know it, it's a good trick :) – Aradnix Sep 6 '14 at 18:09
4

Although many people recommend using the report class to do the thesis, I find more flexible and appropriate the book class. In fact, to avoid troubles with the numbering as is your case, I propose to do the following:

\documentclass[openany]{book} % With this option you can start the chapter in any page, not inly in the odd one such as report does
\usepackage{}
     .
     .
     .
\begin{document}
\frontmatter % This automatically numbers in Roman the pages.
\include{Acknowledgements}
\include{Another preliminary chapter}

\tableofcontents
\listoffigures

\listoftables

\mainmatter % This set the Arabic numbers and reset the page counter to 1.

\include{Introduction}
\include{Methodology}
\include{Experiments}
\include{Results}
\include{Conclusions}

\backmatter % This continue to use Arabic numbers, but not add headers.

\bibliographystyle{ieeetr}
\bibliography{Thesis}    
\end{document}

You don't need to add \clearpage macros after the tables of contents, images or tables.

I use in the example the macro \include (but you can also use \input) for add the chapters to your main file. Is a good practice for long documents such as a Thesis.

  • Thank you for you answer. I have tried the book class before. However, I have been avoiding using it as it adds the page numbers to the top left/right of the pages. It also adds other unwanted material to each page. My university has strict regulations for the thesis layout. I'm required to place page numbers at the bottom centre of the page and have nothing else in the margins, except for the occasional footnote. – Damien Middleton Sep 6 '14 at 14:10
  • I have followed these instructions stackoverflow.com/questions/2235077/… which almost produce the exact result I'm looking for, except that there is still an unwanted line at the top of each page. This line usually underlines the chapter title. If you know how to choose the page number placement and remove ALL other features from the margins using the book class, I'd be grateful for your help. Otherwise, a solution to my original problem using the report class would also be welcome. – Damien Middleton Sep 6 '14 at 14:11
  • 2
    In the book document class, the commands \frontmatter and \mainmatter implicitly execute the commands \pagenumbering{roman} and \pagenumbering{arabic}. If all that's needed is to switch page numbering systems, it suffices to execute the \pagenumbering commands. – Mico Sep 6 '14 at 14:58
  • @DamienMiddleton If you use book or report, to avoid the headings but preserve the numbers at the bottom centre of the page is enough to add in your preamble \pagestyle{plain}. But if you have issues yet, you can use a package for that such as fancyhdr or titlesec. Could you tell us about the other unwanted material with the book class and tell us more about those strict regulations? I think they should have a template that fits with all those requirements. – Aradnix Sep 6 '14 at 17:37
  • 1
    @Aradnix I tried using fancyhdr, as it is explained in stackoverflow.com/questions/2235077/… Perhaps titlesec would have given my what I wanted. I haven't tried. As you suggested, using the book class and \pagestyle{plain} works, but now I have used the suggestion by Mico using the report class and this gives me the desired effect. Thanks for your help. – Damien Middleton Sep 8 '14 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.