4

my question is exactly the same as

Missing labels with feynmf/feynmp?

but the answer there did not solve my problem. I am using WinEdt 7, installed Metapost, and copy and pasted that user's code into my WinEdt. I then

  1. PDFTexify
  2. Opened up fgraphs.mp and then did Tex > MetaPost > MetaPost to generate the fgraphs.1 file
  3. Placed \includegraphics{fgraphs.1} into a separate tex file. When I PDFTexify, I get a diagram that has no labels.

This holds true if I change the fmfgraph environment to fmfgraph*.

Any help would be greatly appreciated!

5

It is better to use feynmp-auto so that if you compile the .tex file with --shell-escape there will be no need of running metapost separately.

\documentclass{article}
\usepackage{feynmp-auto}

% Needed to interpret generated *.1, *.2 etc. as ps files.
%\DeclareGraphicsRule{*}{mps}{*}{}

\begin{document}
Here is a vertex for a local potential in momentum space:
\begin{fmffile}{fgraphs}
  \begin{fmfgraph*}(40,30)
    % Note that the size is given in normal parentheses instead of curly
    % brackets in units of \unitlength (default 1pt).
    \fmfleft{i1,i2} % Define external vertices from bottom to top
    \fmfright{o1,o2}
    \fmf{fermion}{i1,v1,o1}
    \fmf{fermion}{i2,v2,o2}
    \fmf{photon,tension=0.3}{v1,v2}

    % These labels are missing!
    \fmflabel{$\vec{p}$}{i1}
    \fmflabel{$\vec{q}$}{i2}
    \fmflabel{$\vec{p}+\vec{k}$}{o1}
    \fmflabel{$\vec{p}-\vec{k}$}{o2}
  \end{fmfgraph*}
\end{fmffile}
\end{document}

enter image description here

To enable --shell-escape in winedt 7, go to OptionsExecution Modes and then select pdflatex and type as in this figure ↓

enter image description here

Don't forget to press OK before exiting.

  • There should be no need of \DeclareGraphicsRule when feynmp-auto is used. – egreg Sep 7 '14 at 9:24
  • @egreg Valid point. I took the example from the linked answer and didn't take trouble to read the code as it compiled ;-) I will correct now. Thank you. :) – user11232 Sep 7 '14 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.