22

There have been a few questions regarding installing this package in the past, but they now seem to be out of date. I'm using MiKTeX 2.9 and TexMaker. When I try \usepackage{mathtools} in TexMaker it will try to install the package for me but will fail. I took the advice given in this thread: How to install mathtools package?

As suggested I tried installing the mh package using the MiKTeX Package Manager, unfortunately I get the "unknown archive size" error, which I have read means that the package no longer exists. Another thread (lost the link) said you can use the MiKTeX Package Manager to directly install mathtools, however I do not see mathtools listed anywhere in the MiKTeX Package Manager...

So I ask, is the package under a different name? Are there any other ways to install this package?

  • 1
    early in august (2014), the mh bundle was broken in two: mathtools and breqn will be maintained separately from now on. – barbara beeton Sep 6 '14 at 20:51
  • 1
    Ok, but I don't see mathtools on the package manager list anywhere (or breqn for that matter). – ScoobySnacks Sep 7 '14 at 2:49
1

It seems like there is a bug in the MikTeX 5105 basic installer. Using it ("basic-miktex-2.9.5105"), i encountered the issue stated here; the "mathtools" and "breqn" packages do not appear and the "mh" package installation fails with the error mentioned earlier.

To circumvent this problem until a fix is released, download the net installer instead ("setup-2.9.4503"); it's version 4503 which seems to work just fine.

  • 1
    I can't believe it, since 2011 September the latest version is still 2.9.5105? – athos Oct 18 '14 at 14:33
  • Given the popularity of this answer, it seems like maybe this one should be removed. – LondonRob Jan 10 '17 at 17:22
38

Had the same issue. For me it worked after I synchronized manually with the repository using the MikTeX Package Manager (Admin) tool and under the Repository menu using the synchronize.

Then the issue is resolved and the mathtools package appears under the package list.

  • I did not need to use the admin version. – Strategy Thinker Aug 27 '15 at 14:02
6

In cmd type mpm --verify=mathtools that will tell if mathtools is installed, not installed or unknown.

If mathtools is not installed: in cmd type mpm --install=mathtools to install mathtools.

If mathtools is unknown: in cmd type mpm --find-updates or mpm --update-db and then install.

Alternative: in cmd type mpm to start MiKTeX Package Manager then Repository->Synchronize

Find mathtools

Then search for mathtools -> select row mathtools -> right click -> install.

4

The mh package has recently been split into mathtools and breqn, with different maintainers, and they certainly appear in MiKTeX Package Manager:

enter image description here

Which version of mpm do you have?

  • Not sure what you mean by mpm. I have miktex 2.9, on windows 7. I see the mh bundle like you showed, but when I try and install it I get the "unknown archive file size error". – ScoobySnacks Sep 7 '14 at 2:48
  • Mpmis the acronym for MiKTeX package manager. It mentions the mh package, but it's an error: it was removed from the archive, as you can see on looking at CTAN (for instance at dante.ctan.org/tex-archive/systems/win32/miktex/tm/packages). You now must install separately mathtools and breqn. – Bernard Sep 7 '14 at 9:39
2

I ended up downloading and manually installing the mathtools package, this was easier I think than switching to an earlier version of miktex. I think emher is right and that this is a bug in miktex 5105 where those two packages just don't appear in the list. For anyone else with the same problem you can download the package here.

To install the package I typed "latex mhsetup.dtx" followed by "latex mathtools.dtx" in the windows command line (after cd'ing to the directory I downloaded the package first of course).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.