2

I am having trouble beginning to use the tike-cd package for commutative diagrams. Whenever I use the \arrow or \ar command for an arrow, I come up with the errors:

"! Package tikz-cd Error: Arrow direction argument must only contain the letters u, d, l, r.See the tikz-cd package documentation for explanation".

"! Package pgfkeys Error: I do not know the key '/tikz/r' and am going to ignore it. Perhaps you misspelled it.See the pgfkeys package documentation for explanation."

I have looked over the documentation for tikz-cd, and that was of no help, and I don't understand the second error; I tried to look up pgfkeys for help, and tried to import it into the document but still come up with the same error. Am I wrong to assume all the packages I need in the preamble to use tikz-cd is just tikz-cd? An example of a document that does not compile ,and returns this specific error, is:

\documentclass[11]{article}

\usepackage{tikz-cd}

\begin{document}

\begin{tikzcd}
A \arrow[r] & B
\end{tikzcd}

\end{document}

I am using texmaker. Originally thought I had miktext (I have always used this on my windows machines), but found I haven't installed it.

Solution: Installed an updated version of MacTex and used Tex Live Utilities as @egreg recommended.

closed as off-topic by egreg, Adam Liter, Mensch, Thorsten, user31729 Sep 9 '14 at 16:54

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.SX! Your example compiles fine for me (11 should be 11pt, however). I suspect a spurious character in your source; try retyping the whole line containing \arrow[r]. – egreg Sep 9 '14 at 15:40
  • As a sidenote, MiKTeX on Mac sounds strange. MiKTeX is a TeX distribution for Windows. Just out of curiosity, are you running MiKTeX in a virtual machine or with Boot Camp, and why? – mvkorpel Sep 9 '14 at 15:46
  • @egreg : Unfortunately that didn't work. Because it compile d fine for you, could it be a problem outside of the '\arrow' command or package and instead with texmaker that I'm over looking? – Johann Miller Sep 9 '14 at 15:50
  • Another possibility is that your version of tikz-cd is old and doesn't support that syntax. In the .log file you should have something like tikz-cd 2014/03/08 v0.9b Commutative diagrams with tikz; please report what you find there. – egreg Sep 9 '14 at 15:52
  • 4
    This question appears to be off-topic because it is about a problem due to an outdated version of the software. – egreg Sep 9 '14 at 16:33

Browse other questions tagged or ask your own question.