1

I am trying to install the mtpro2 font for texlive2014 following the commands listed http://pctex.com/kb/62.html

Everything is working smoothly until the last command:

updmap-sys --enable Map mtpro2.map

which gives me the following error message:

exec: 30: updmap: not found

I am not sure what is the cause of this error. The only posts I could find online regarding such error are fairly old and related with Texlive 2008...

I tried to install this font on a Windows PC and another Linux PC and everything worked fine. Would you have any insight or tip regarding this type of error message ?

Thanks,

  • 1
    updmap-sys --enable Map=mtpro2.map is the usual syntax. Is PATH set correctly? Note that I see the link suggests that syntax only for Windows. However, that's what I've always used and I've never used TL on Windows. – cfr Sep 9 '14 at 20:56
  • On a UNIX system (including my Linux box), error 30 is EROFS, Read-only file system. Do you have write permission on it? This may be wholly irrelevant, as I see a different error on Mac OS when I don't have write permission. The "not found" looks more like updmap isn't in the user's PATH. – Adam Maxwell Sep 9 '14 at 21:26
  • @egreg Note that the OP is using TL 2014 which definitely provides these commands ;). Besides, the error is coming from the final line of updmap-sys which is just a 30-line wrapper around updmap. So the system clearly has updmap-sys and definitely ought to have updmap unless something fairly serious is wrong with the TeX Live installation. – cfr Sep 9 '14 at 22:24
  • @cfr Oh, sorry, I misinterpreted the post. – egreg Sep 9 '14 at 22:25
  • 1
    If I run PATH=/usr/bin/ /usr/local/texlive/bin/updmap-sys --help, I get /usr/local/texlive/bin/updmap-sys: line 30: exec: updmap: not found which further suggests to me that this is a problem with PATH or a more serious one with the installation of TL. If updmap-sys is being invoked without a full path, it would be odd that updmap is not also found. But if updmap-sys is being invoked with a full path specification, it is very possible that updmap might not be found. @AdamMaxwell I'm pretty sure 30 is the line number and not an error code. – cfr Sep 9 '14 at 22:28
1

The problem was in the definition of PATH.

After updating the PATH, I was able to run the updmap command properly. It should be said that the code 30 was indeed related to a line number and not an error code as updmap is called on line 30 of updmap-sys.

Thanks !

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.