8

I am using the font IM FELL English PRO (open-source otf here) via the fontspec package, and when I tried typesetting the characters \"{a}, \'{n} or \"{o}, I got this error:

xdvipdfmx:fatal: Type2 Charstring Parser: Parsing charstring failed: (status=-1, stack=5)
Output file removed.

Here is the MWE:

\documentclass{minimal}
\usepackage{fontspec}
\setmainfont{IM FELL English PRO}
\begin{document}
\'{n}
\end{document}

I am using XeTeX version 3.14159265-2.6-0.99991 and fontspec version 2.4a. Another user also got the same error using LuaTeX with this MWE.

Those characters do exist in this font. There are other characters that give this error (e.g. in this question), but not all accented characters have the problem; e.g. \"{u} is ok. The error also goes away if I change to another font, such as Arial. There is another similar thread where the OP there got the same error with some fonts but not others. It was suggested there for various reasons that I should start a new question.

The font developer Igino Marini told me the font had been generated in FontLab Studio and had passed the Microsoft Font Validator, and no problems have been reported to him outside of LaTeX.

Many thanks for looking into this.

  • 2
    I get the same error with LuaLaTeX. On the other hand, otfinfo reports the existence of nacute in the font. – egreg Sep 9 '14 at 21:34
  • 2
    Note that U+0144 LATIN SMALL LETTER N WITH ACUTE does exist in the font, which I checked with fontforge; I guess it's the culprit. Also \iffontchar\font"0144 returns true. – egreg Sep 9 '14 at 21:41
  • I tried with TL 2012, which predates the adoption of the HarfBuzz library; again the error is the same: ** WARNING ** "seac" character deprecated in Type 2 charstring. ** ERROR ** Type2 Charstring Parser: Parsing charstring failed: (status=-1, stack=5) – egreg Sep 9 '14 at 22:09
  • 1
    @egreg I discovered that I can get all the characters to work by re-exporting from FontForge -- this might offer some clues. – Lin Yangchen Sep 25 '14 at 17:29