6

Why does the following BibTex-entry not include the publisher?

@book{billingsley,
  title={Convergence of Probability Measures},
  author={P. Billingsley},
  year={1968},
  publisher={Wiley, New York}
}

There is a warning that the journal is empty, but yeah, it is exactly how I have copied it from google scholar, so I have no idea what to do.

The output is only title, author, and year.

What can I do? Sorry, I am a beginner.

Here is a MWE:

\documentclass[11pt,a4paper,titlepage]{memoir}

\usepackage[OT1]{fontenc}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[sc]{mathpazo}
\usepackage{amsmath,amssymb,amsfonts,mathrsfs}
\usepackage[amsmath,thmmarks]{ntheorem}
\usepackage{graphicx}
\usepackage{soul}
\usepackage{pdfpages}

\begin{document}

text \cite{billingsley}

\bibliographystyle{plain}
\bibliography{refs}


\end{document
  • Well, it may be due to many factors. I do not know what bibliographic style you're using. Could you add please a full MWE? – Aradnix Sep 10 '14 at 8:25
  • thank you for trying helping me. I am really a beginner, so I am not sure of what I should post a minimal working example. Only of the bibtex or of the whole file? – user136457 Sep 10 '14 at 8:27
  • The problem is that for some books the publisher is included whereas for others it is not. – user136457 Sep 10 '14 at 8:27
  • A minimal working example (MWE) should illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. Please read the link. – Aradnix Sep 10 '14 at 8:35
  • 1
    You can also take the bibtex entry from the publisher's site directly instead of Google scholar. They are more likely to be in the correct format that publisher wants to be cited with. – Harald Sep 10 '14 at 8:57
3

To long for a comment.

I have reduced your MWE to the following code, running without errors and returns the desired result. My system here is MiKTeX 2.9, updated yesterday. Styles plainor alpha do not change the publisher output.

Which tex districution do you use? And are youre packages up to date? You can check this by adding a \listfiles before the \documentclass ... and compare the resulting list in the log file with this:

 *File List*
filecontents.sty    2011/10/08 v1.3 Create an external file from within a LaTeX document
  memoir.cls    2013/05/30 v3.7b configurable book, report, article document class
   ifpdf.sty    2011/01/30 v2.3 Provides the ifpdf switch (HO)
  ifetex.sty    2011/12/15 v1.2 ifetex
 ifxetex.sty    2010/09/12 v0.6 Provides ifxetex conditional
ifluatex.sty    2010/03/01 v1.3 Provides the ifluatex switch (HO)
    etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)
   mem11.clo    2008/01/30 v0.3 memoir class 11pt size option
mempatch.sty    2009/07/24 v6.0f Patches for memoir class v1.6180339
 fontenc.sty
   t1enc.def    2005/09/27 v1.99g Standard LaTeX file
   babel.sty    2014/03/24 3.9k The Babel package
 bblopts.cfg    2006/07/31 v1.0 MiKTeX 'babel' configuration
 english.ldf    2012/08/20 v3.3p English support from the babel system
inputenc.sty    2014/04/30 v1.2b Input encoding file
    utf8.def    2008/04/05 v1.1m UTF-8 support for inputenc
   t1enc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
  ot1enc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
  omsenc.dfu    2008/04/05 v1.1m UTF-8 support for inputenc
no-publisher.bbl

The shorted MWE is:

\listfiles
\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@book{billingsley,
  title     = {Convergence of Probability Measures},
  author    = {P. Billingsley},
  year      = {1968},
  publisher = {Wiley, New York},
}
\end{filecontents*}


\documentclass[11pt,a4paper]{memoir}

\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc}

\begin{document}

text \cite{billingsley}. 

\bibliographystyle{alpha} % plain
\bibliography{\jobname}

\end{document}

And the result on my system is:

enter image description here

Please run exactly this MWE on your computer and compare your results with mine.

  • thank you for your answer. my babel.sty, english.ldf, inputenc.sty are not up to date. But the output is exactly the same.. – user136457 Sep 10 '14 at 12:14
  • 1
    Okay. In the MWE we saw the publisher. I guess now you have a bib entry before billingsley causing an error. If you find this error and correct it the bib entry billingsley should work. Please have a look in your file .blg and search there for error messages or warnings. – Mensch Sep 10 '14 at 13:40
  • 3
    you are right. I forgot to put a comma in an entry before. unbelievable. Now it works perfectly! Thank you for your help! This did not only help me to find the error but also to get used to the process of error finding, e.g. checking the file list. Thank you very very much for that – user136457 Sep 10 '14 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.