8

I've been working with classicthesis for a few weeks now for my thesis and I would like to use the following package instead of the Palatino font: \usepackage{garamond}

You certainly know that, in order to use it, you have to write this piece of code before writing anything in the body, just after \begin{document}: \garamond

It works with a simple test made with the article class (or even book), but it does not work with Classicthesis. Therefore, here is my question: Where do I have to put \usepackage{garamond} in the preamble? Do I have to change directly classicthesis.sty?

This is the code of my preamble :

% book example for classicthesis.sty
\documentclass[11pt,a4paper,footinclude=true,headinclude=true]{scrbook} % KOMA-Script book
\usepackage[T1]{fontenc}   
\usepackage[applemac]{inputenc}    
\usepackage[frenchb]{babel}
\usepackage{setspace} 
\usepackage{hyperref} 
\usepackage[tight,french]{minitoc}
\usepackage{apacite}
\usepackage{lipsum}
\usepackage[parts,pdfspacing,dottedtoc,eulerchapternumbers]{../classicthesis} % ,manychapters
%\usepackage[osf]{libertine}
\usepackage{ebgaramond}
\FrenchFootnotes
\usepackage{amsthm}
\usepackage{lineno}
\setcounter{tocdepth}{3}
\setcounter{secnumdepth}{3}
\AtBeginDocument{\renewcommand{\thepart}{\Roman{part}}}
\frontmatter
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\def\ptctitle{Table}
\def\mtctitle{Table}
\def\stctitle{Table}
\setlength{\mtcindent}{0pt}
\renewcommand{\mtifont}{\normalsize\scshape\lsstyle}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

%%%%%%%%%%%%%%%%%%%%%%%modifie la taille des numéros de chapitres%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\ifthenelse{\boolean{@eulerchapternumbers}}% font for the chapter numbers
    {\newcommand\mychapterNumber{\fontencoding{U}\fontfamily{eur}\fontseries{b}\fontsize{28}{29}\selectfont}}%
    {\newcommand\mychapterNumber{\fontencoding{T1}\fontfamily{pplj}\fontsize{25}{26}\selectfont}}

\ifthenelse{\boolean{@linedheaders}}%
    {%
    \titleformat{\chapter}[block]%
        {\relax}{\titlerule\vspace*{.9\baselineskip}\\\raggedleft{\color{halfgray}\mychapterNumber\thechapter}}{1.2em}%
        {\raggedright\spacedallcaps}[\normalsize\vspace*{.8\baselineskip}\titlerule]%
    }{%
    \titleformat{\chapter}[block]%
        {\relax}{{\color{halfgray}\mychapterNumber\thechapter}}{1.2em}%
        {\raggedright\spacedallcaps}[\normalsize\vspace*{.8\baselineskip}\titlerule]%
    }
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
\begin{document}

%   \pagestyle{scrheadings}
%   \manualmark
%   \markboth{\spacedlowsmallcaps{\contentsname}}{\spacedlowsmallcaps{\contentsname}}






\pagestyle{scrheadings}




\tableofcontents
7
  • usepackage{<packagename>} has always have to be in the preamble, you'll get an error otherwise. In this case i would say putting it after Package classicthesis should do the trick. Altough i haven't test, cause there is no code to test.
    – Johannes_B
    Commented Sep 10, 2014 at 8:55
  • 2
    Hi, I edited your post in order to give better formatting. Note that I deleted the personal stuff. This is just because we do like to have a clear question & answer structure here. In order to help you: You should provide some minimal compilable code for us. Nobody wants to set up a new document which might not replicate what you are having. Show some code and you will get help quickly.
    – LaRiFaRi
    Commented Sep 10, 2014 at 8:57
  • There was a third one : \usepackage{ebgaramond}. That is the answer I tried and it works.
    – domi
    Commented Sep 11, 2014 at 20:06
  • @domi: There was no 3rd one -- if so, I would see it;-)
    – user31729
    Commented Sep 11, 2014 at 20:47
  • Of course it was yours :-)) : "On TeXLive 2014, there is no garamond.sty, but ebgaramond.sty. Just include it after \usepackage{classicthesis} to 'guarantee`, that the font change is activated." That is what I did.
    – domi
    Commented Sep 11, 2014 at 20:50

2 Answers 2

6

On TeXLive 2014, there is no garamond.sty, but ebgaramond.sty. Just include it after \usepackage{classicthesis} to 'guarantee`, that the font change is activated.

\documentclass[10pt]{book}
\usepackage{classicthesis}

\usepackage{ebgaramond}

\usepackage{blindtext}

\begin{document}
\Large
\chapter{Garamond}%

\blindtext[10]

\end{document}

enter image description here

enter image description here

1
  • It works the way you indicate.
    – domi
    Commented Sep 11, 2014 at 12:59
12

I have already seen the garamond package, but in my opinion it's not the best option.

There are other options available, in particular for better supporting math.

  1. \usepackage{ebgaramond,newtxmath,ebgaramond-maths}

    enter image description here

  2. \usepackage{ebgaramond}\usepackage[ugm]{mathdesign}

    enter image description here

  3. \usepackage{garamondx} (requires installing the font with getnonfreefonts)

    enter image description here

Here's the source

\documentclass[10pt]{scrbook}
\usepackage[eulerchapternumbers]{classicthesis}

% option 1
%\usepackage{ebgaramond,newtxmath,ebgaramond-maths}

% option 2
%\usepackage{ebgaramond}\usepackage[ugm]{mathdesign}

% option 3
\usepackage{garamondx}

\usepackage{kantlipsum}

\begin{document}
\chapter{Garamond}

We start with a known formula
\[
\int_{0}^{\infty} e^{-x^{2}}\,dx=\frac{\sqrt{\pi}}{2}.
\]
\kant[2]

\end{document}
3
  • I don't know the O.P.'s distribution, but garamondx is included in MiKTeX. Also, one drawback of eb-garamond is that it has no boldface font.
    – Bernard
    Commented Sep 10, 2014 at 10:03
  • 2
    @Bernard The absence of a boldface font is not a problem: nobody should use boldface Garamond to begin with. I use to say it's like Ben Hur wearing a wristwatch.
    – egreg
    Commented Sep 10, 2014 at 10:15
  • 1
    @egreg: Buster Keaton did it in The Three Ages (actually , it was a wrist-sun dial:-). That said, one may need bold or semi-boldface Garamond for good reasons.
    – Bernard
    Commented Sep 10, 2014 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .