0

I am using Texmaker 4.3 (downloaded from their website) and Texlive 2014 (also downloaded) on Ubuntu 12.4 fork ElementaryOS in 64bit.

I recently completely reinstalled my OS and compiling a PDF in Texmaker does not work (it did work before the reinstall, but that may have been Texlive 2013 or even 2012, though I am not sure. also it was 32bit). By "not working" I mean that if I click the PDFLaTeX button, my PC works and I see latex output, but there is no pdf created (and if one exists previously, it's not changed). I see no conpile errors. I google a bit, but I was not able to find a solution. My configuration of Texmaker is

latex -interaction=nonstopmode %.tex
pdflatex -synctex=1 -interaction=nonstopmode %.tex

Some more information: Compiling works in Terminal (with pdflatex name.tex). For the current document I don't have a bibliography, but in general I use biblatex with biber.

2
  • Welcome to TeX.SX! Others might be able to identify your problem by looking at the .log file produced when you click the PDFLaTeX button.
    – mvkorpel
    Commented Sep 10, 2014 at 15:48
  • No log file is created and actually, I forgot to mention this, when I press the button I get a pop up about logfile not being found.
    – anjuta
    Commented Sep 10, 2014 at 15:50

2 Answers 2

2

In general PATH changes are better off added in ~/.profile (for personal use) or added to /etc/profile or added in the front of the PATH variable in /etc/environment. In any case always make a back up first.

Why not ~/.bashrc? It will only be executed in a bash context. So when an editor is started from a menu, and it makes a system call to start LaTeX, it is not a bash shell the calls LaTeX, or at least not one that has read ~/.bashrc.

Adding it to say ~/.profile, then this is global (for the user) and is read once and for all at login.

1

I solved the problem by something very simple: In Options -> Configure Texmaker I typed the full path for pdflatex's and lualatex's and biber's binary. I got the full path by opening the terminal and typing "which [pdflatex|lualatex|biber]". It works now.

However, I don't understand WHY providing the full path to Texmaker is necessary. In Terminal, I can use these binaries just fine. I thought Texmaker makes use of the same environment variables (or whatever these are called in Linux) as the terminal. Or do I have to configure a search path for Texmaker individually? Then this might be the reason. I am still looking for more ideas to understand this behaviour, even though I found a work around.

5
  • Let me make one guess: Did you add the TeXLive PATH to ~/.bashrc and afterwards start TeXmaker from a menu or by double clicking on a .tex file? That will not work. The PATH change should go into ~/.profile (then log out and in againg for it to take effect).
    – daleif
    Commented Nov 25, 2014 at 11:52
  • Yes, it is indeed in ~/.bashrc. I'll try your answer. Is adding them to ~/.profile the right thing to do for all paths to binaries?
    – anjuta
    Commented Nov 27, 2014 at 9:32
  • 1
    I would guess so. ~/.bashrc only makes it available for stuff that runs through a shell that also remembers to run ~/.bashrc. BTW: where did you learn that you should add the PATH change to ~/.bashrc` in the first place (we'd like to have some of those resources updated)
    – daleif
    Commented Nov 27, 2014 at 9:52
  • Thanks for your explanation. It works indeed! As for adding the PATH to .bashrc: I never knew about this .profile file. I thought that .bashrc is the best place for everything ... and I knew about /etc/profile for global changes. But thanks to you, next time I'll know better about what to do. You should post this solution as an answer, I think. Then I can accept it.
    – anjuta
    Commented Dec 3, 2014 at 15:47
  • I've added a writeup
    – daleif
    Commented Dec 3, 2014 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .