1

I installed the Full scheme of Tex Live 2014 with install-tl on RHEL 5. I find that it no longer has the texdoc-accessible PDF documentation. Am I missing something? Or is excluding the documentation a community decision that I was not aware of?

$ texdoc amsmath
Sorry, no documentation found for amsmath.
If you are unsure about the name, try searching CTAN's TeX catalogue at
http://ctan.org/search.html#byDescription.

$ texdoc tikz
Sorry, no documentation found for tikz.
If you are unsure about the name, try searching CTAN's TeX catalogue at
http://ctan.org/search.html#byDescription.

I think I have my PATHs correctly set, because I could compile a past project out-of-the-box. Anyways, I probably still missed something.

How do I install all the PDF documentation seamlessly?

UPDATE

The output of texdoc -f is:

~/personal/local/texlive/texmf-dist/scripts/texdoc/texdoclib.tlu 0.85
Configuration files are:
    active      ~/personal/local/texlive/texmf-dist/texdoc/texdoc.cnf
Recommended file(s) for personal settings:
    ~/.texlive2014/texmf/texdoc/texdoc.cnf

This is a TeX Live 2014 that I installed myself, with a custom installation prefix ~/personal/local.

UPDATE (Terminal outputs)

Here is the (failure) output of texdoc -d tikz: http://pastebin.com/Sxq25TeA
And here is the (success) output of texdoc -d latex: http://pastebin.com/dMC9W7Yh, which I find weird because I get the documentation for KOMA-script.

UPDATE (Problem solved)

This option had to be enabled:

[X] Install macro/font doc tree

I don't think a full installation scheme is needed. In my case, I customized the packages and disabled the ones that I do not need (mostly the ones for characters of non-Latin languages).

  • What's the output of texdoc -f? A full install will surely include the doc parts, there has been no change, AFAIK. – egreg Sep 11 '14 at 9:39
  • what tex live are you using? is it one installed by your system (as linux systems do), or did you install it yourself? (fwiw, my self-installed, recently updated tex live texdoc finds the (huge) pgf doc, no problem.) – wasteofspace Sep 11 '14 at 15:41
  • @egreg, I have updated the question in response to your comments – Kit Sep 19 '14 at 1:47
  • Does texmf-dist/doc/generic/pgf/pgfmanual.pdf exist in the texmf tree? (This is the documentation you should get when you do texdoc tikz. So the answer will tell you whether the problem is missing documentation or a problem finding the documentation.) – cfr Sep 19 '14 at 2:26
  • texdoc -d aardvark may be helpful. (Where aardvark is some actual package name - I just wanted something texdoc definitely wouldn't find to see if it told me anything which might be helpful.) – cfr Sep 19 '14 at 2:29
1

Probably the path for info is missing, something like

INFOPATH=/local/texlive/2014/texmf-dist/doc/info:$INFOPATH; export INFOPATH

I'm using the file .profile (not RH, but openSuse) to set pathes for TeX:

PATH=/local/texlive/2014/bin/x86_64-linux:$PATH; export PATH
MANPATH=/local/texlive/2014/texmf-dist/doc/man:$MANPATH; export MANPATH
INFOPATH=/local/texlive/2014/texmf-dist/doc/info:$INFOPATH; export INFOPATH

EDIT:

A comment below is doubtful about the need to set the MANPTH and the INFOPATH. But the texlive documentation as of today (http://tug.org/texlive/doc/texlive-en/texlive-en.html) says:

create symlinks in standard directories: This option (Unix only) bypasses the need to change environment variables. Without this option, TEX Live directories usually have to be added to PATH, MANPATH and INFOPATH

So the answer depends upon some installation options. I don't see any harm done by adding these pathes, but, well, I'm a user, not an IT guy.

  • 1
    Better not to set MANPATH at all. At least, if you are using any recent version of the tools. I'm not sure of the details, but man now pulls the path from PATH or something. At any rate, I know it is now recommended to leave it empty. On my system INFOPATH is also empty. Moreover, I don't think either of these have anything to do with texdoc. – cfr Sep 19 '14 at 2:21
  • For the record, I have enabled the symlinks option, but the problem is still there. – Kit Sep 22 '14 at 3:49
  • Also, I browsed the paths that you were referring to. They're mostly empty. – Kit Sep 22 '14 at 8:09
  • @Kit The pathes in my answer refer to my computer. I have no idea where you installed texlive! Please adapt the path! – Keks Dose Sep 22 '14 at 10:38
  • @KeksDose, yes, sorry, I adapted the paths according to my installation, of course. – Kit Sep 23 '14 at 0:45
1

Problem solved

This option had to be enabled:

[X] Install macro/font doc tree

I don't think a full installation scheme is needed. In my case, I customized the packages and disabled the ones that I do not need (mostly the ones for characters of non-Latin languages).

Thanks to everyone who offered their opinions in the comments :)

0

The problem is that texdoc displays documentation from the doc trees which are part of the various texmf trees on your system. If you opt not to install the macro/font doc tree then you are effectively telling tlmgr to skip the documentation.

To check this is the problem, run

tlmgr option docfiles

If the option is set to 0 then you don't have the documentation files installed.

tlmgr option docfiles 1

will change this option. However, this will not, unfortunately, install documentation for packages already installed. In effect, this means that you can only install the documentation by rerunning the original installer as described in Kit's answer.

but I am not entirely certain as I've never opted out of the documentation when installing.

  • I actually did this, but I did not "feel" the documentation being downloaded (it was too quick). The documentation folders were empty as well. – Kit Sep 23 '14 at 7:58
  • @Kit That's too bad. As I said, I couldn't test this because I didn't disable that option in the first place. I wonder if it is because this option affects only what is installed on a package-by-package basis so that it only affects packages as they get installed or updated in the future, rather than applying also to the documentation for packages you've already installed. If so, I wonder if there is a 'clean' way to get that stuff installed without reinstalling the whole thing. – cfr Sep 23 '14 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.