1

I'm really new to LaTeX and am having a problem with mathtools.sty. I am using MikTeX and Texmaker.

When I try to create the pdf (compile?) it gives me the error:

! LaTeX Error: File `mathtools.sty' not found.Type X to quit or to proceed,or enter new name. (Default extension: sty)Enter file name:! Emergency stop. \usepackage

I looked this problem up on Google, and found a thread on this place. It said to open the Package Manager and download it there. I opened the Package manager, downloaded mathtools from it by pressing the "+". After doing this it still comes up with the same error, that mathtools.sty is missing.

I have tried reinstalling everything and still nothing works.

I really hope you can help and explain in a simple manner, so that even I can understand :)

1

Did you launch MiKTeX Package Manager as administrator? That might explain. Always run as administrator if you want a system-wide installation (for any user).

Double-clicking on + installs the package, right-clicking on + only selects the package for further installation, this lets you select several packages then install them in a single stroke instead of one after the other. To install you have to right-click on the mathtools line and select install, or click on the Tasksmenu and select ‘Install’. That's all.

  • You're right. I always used + with a right-click to select. I'll change that at once. – Bernard Sep 11 '14 at 12:48
  • Yes i did open as administrator. I am now trying to find the file "mathtools.sty" on the internet, but it is nowhere to be found. I only get some useless "Latex-macros" files that i can't use for anything. I don't even know what folder to insert them into, there is no information for new guys like me at all. All the information is for people that already understands everything, and that is really annoying :( – Ravn Sep 11 '14 at 18:52
  • same problem here – Chen Stats Yu Oct 18 '14 at 15:18
  • @Chen Stats: I don't remember where I gave some other hints, so I re-explain here: there has been a problem with mathtools recently, due to the splitting of the mh package in two parts (with different maintainers). You should first synchronise MiKTeX Package Manager (menu Repository-> Synchronize) to ensure the packages database is up-to-date. Then select mathtools in MPM, right-click on it and ask for installing it. That should be all you have to do – Bernard Oct 18 '14 at 15:32
  • @Bernard After half an hour's research, I sorted it out. All I need to do , is to update my MixTex. THANKS! – Chen Stats Yu Oct 18 '14 at 15:43
1

You should install it manually.

  • You can find mathtools.sty here: mathtools.tds.zip

  • unpack the whole content directly into MikTeX 2.9 folder

  • run Maintenance (Admin)\Settings (Admin)

  • execute Refresh FNDB and Update Formats

and you're ready to use it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.