6

I installed MiKTeK 2.9.4321 in a locked down environment. I don't believe that we can directly download the entire thing from outside, and the aforementioned version is the one that we have on a CD, and it is also the one for which I got permission to install.

Since I am the sole user of the computer, I installed it as non-administrator. If I rely on an administrator to install MiKTeK, I won't be able to update the packages that were included with his installation.

I ran into a problem updating the packages. The Select All button is grayed out. There are countless packages (I installed every one of them), so going through to check off individual packages is infeasible. All of the packages are "updateable", as the list is titled "Updateable Packages".

For context, some of the packages should be up-to-date already, and some should not be. All the ones that were installed with the installation of MiKTeK are not up to date because they came from the CD. All the packages installed afterward are up to date, but that still means there are countless packages that are not up to date.

Wy would the Select All button be grayed out? Is there any other way to update all packages without having to check off millions of checkboxes?

This question has been posted at:

  • 2
    When there is an MikTeX internal update required you have to download it first, then it allows you to update the actual TeX packages. – percusse Sep 11 '14 at 19:46
11

If I understand your question right:

The MiKTeX update process has generally three parts:

  1. If there are changes in the basic system (miktex.exe etc.) MiKTeX downloads and updates only this files. Then the update process has to be started once again.
  2. Are there packages to be deleted? If yes, then the MiKTeX update manager is programmed to mark only that packages to be deleted and starts this process.
  3. Are there packages to be updated? Now these packages are markable and the user can start this process.

So it can be you have to start the update manager for 3 times ...

  • The problem is that there is no message explaining that certain packages were selected for deletion already, and that is why one cannot select packages for updating. Then again, it is freeware, so one cannot complain about the functionality. – user36800 Sep 29 '14 at 0:11
2

In my first pass, I simply let the update finish with the packages selected by default. It seems that only obsolete packages are selected, and the purpose of the 1st update was to clear them out. In my 2nd attempt at updating, it seems that all the remaining packages were checked off for updating. And Select All was not grayed out. I pressed it to make sure that all packages were selected. With that, the problem is solved. I hope. I'm still waiting for the much more substantial 2nd update to complete.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.