2

This question already has an answer here:

I am creating a greek document using package babel. The main problem is that the contents the pdf viewer creates are not displayed in greek, but in "greeklish".

Okular

okular

Adobe Reader

adobe reader

At first I thought that it was Okular's issue but I get the same behaviour on adobe reader and adobe acrobat, so I don't think that has to do with the reader.

My TeXLive version is TeX 3.14159265 and I am using pdfLatex.

A simple code is

\documentclass[11pt,a4paper]{book}

\usepackage[english,greek]{babel}
%\usepackage[utf8]{inputenc}
\usepackage[iso-8859-7]{inputenc}
\usepackage{kerkis}
\usepackage[pdfencoding=auto]{hyperref}
%\usepackage[unicode]{hyperref}
\usepackage{bookmark}

\begin{document}
 \tableofcontents
 \chapter{Περίληψη}
%  \begin{otherlanguage}{greek}
% \addchap{\texorpdfstring{Per'ilhyh}{Περίληψη}}
% Per'ilhyh
% \end{otherlanguage}
  \section{Πρώτη Ενότητα}
  \section{Δεύτερη Ενότητα}
 \chapter{Δεύτερο Κεφάλαιο}
  \section{Πρώτη Ενότητα}
  \section{Δεύτερη Ενότητα}
 \chapter{Τρίτο Κεφάλαιο}
  \section{Πρώτη Ενότητα}
  \section{Δεύτερη Ενότητα}
\end{document}

I've tried to use options unicode or pdfencoding=auto to the hyperref package, but without any luck. I've also changed the encoding from iso-8859-7 to utf8 but I get an error

! Argument of \UTFviii@three@octets has an extra }. <inserted text> \par l.13 \chapter{��������} Runaway argument?

Any idea why is this happening and how to fix it?

marked as duplicate by egreg table-of-contents Sep 12 '14 at 10:41

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I think this is a case for \chapter[\texorpdfstring{Πρώτο κεφάλαιο}{proto kefalaio}]{Πρώτο κεφάλαιο} – Johannes_B Sep 12 '14 at 9:49
  • You need to load hyperref of course. – Johannes_B Sep 12 '14 at 9:56
  • @Johannes_B : This doesn't change it. instead of having Pr'wto Kef'alaio I now have proto kefalaio while I want Πρώτο Κεφάλαιο. You are right about hyperef. I've edited my question. – Thanos Sep 12 '14 at 9:57
  • 1
    Why are you insisting in using iso-8859-7 instead of UTF-8? If I use UTF-8 and \usepackage[unicode]{hyperref}, I get the right thing. – egreg Sep 12 '14 at 10:19