I tried to compile some trivial LaTeX files with the shipped XeLaTeX on centos 7:

$ xelatex trivial.tex
This is XeTeX, Version 3.1415926-2.5-0.9999.3 (TeX Live 2013)
 restricted \write18 enabled.

kpathsea: Running mktexfmt xelatex.fmt
/usr/bin/mktexfmt: line 395:
/usr/share/texlive/texmf/texconfig/tcfmgr: No such file or directory
fmtutil: config file `fmtutil.cnf' not found.
I can't find the format file `xelatex.fmt'!
$ rpm -q texlive-xetex
$ cat trivial.tex

\title{Hello World!}


Upon reading this I tried the following

TEXMF=/usr/share/texlive/texmf-dist xelatex trivial

but it did not help. How can I fix it?

  • If it tells you which file is missing, you can generally search the package repo for the package that provides it, and install that. In this case, that wouldn’t work because the ,fmt files are not listed as provided by any package, so you’d have to search for the xelatex pattern.
    – Davislor
    Nov 11, 2021 at 4:38
  • The other missing file, fmtutil.cnf, is in texlive-kpathsea, so make sure that is installed.
    – Davislor
    Nov 11, 2021 at 4:39

2 Answers 2


I had to install the pseudo-package texlive-collection-xetex to make it work.

Here is the authoritative reference: TeXLive on Fedora


I had the same issue with getting XeLaTeX to work on CentOS 7. After numerous trials, I found a solution for a working xelatex, by installing the tinytex package (without root privilege) :

  1. Install tinytex : https://yihui.org/tinytex/

  2. Make the environment to find tinytex's xelatex first on your path, such as adding: export PATH="~/bin":$PATH in your .bashrc

  3. Using the tinytex manager to search and find your missing component needed by latex: https://yihui.org/tinytex/#maintenance

  4. Install the package containing the missing component in step 3; repeat 3 and 4 till all dependent components are installed

  5. Now, compiling LaTex document just works!

  • Welcome to the site! This seems to be a nice answer to a different question?
    – Davislor
    Nov 11, 2021 at 4:50
  • Thanks for the greetings! Actually tinytex has xelatex in its collection of tools, so I will rephrase my answers to indicate this is a solution to get xelatex working on centOS 7 without super user rights etc. (I had root right on my workstation with centOS, but still couldn't get it working for my jupyter notebook tex file compilation).
    – Ipstone
    Nov 16, 2021 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .