1

The bottom line is that TeXworks doesn't recognize my environment variables, but the command line compile commands (pdflatex and bibtex) do just fine.

I'm running Linux Mint 17 KDE, and I installed texlive-full and texworks through the package manager. I use Dropbox, and share files with others, so it's crucial to collect files in other, central locations (e.g. a .bib file that is used by many projects).

On a previous machine, running Mint 13, the solution was to set the environment variables TEXINPUTS, LATEXINPUTS, BIBINPUTS, and BSTINPUTS by putting these four lines into my .bashrc file:

export TEXINPUTS=".//:/home/my_user_name/Desktop/Dropbox/latex_files/tex//:$TEXINPUTS"
export LATEXINPUTS=".//:/home/my_user_name/Desktop/Dropbox/latex_files/tex/latex//:=:$LATEXINPUTS"
export BSTINPUTS=".//:/home/my_user_name/Desktop/Dropbox/latex_files/bibtex/bib//:$BIBINPUTS"
export BIBINPUTS=".//:/home/my_user_name/Desktop/Dropbox/latex_files/bibtex/bst//:$BSTINPUTS"

This worked perfectly on my old system. But now, TeXworks doesn't seem to find these paths. However, I know the environment variables are being set properly, because if I use the command line tools (pdflatex and bibtex) everything works perfectly.

I searched around, and couldn't find this exact issue. The closest was this question: TeXworks doesn't see packages installed by tlmgr. But that wasn't helpful. As suggested in that thread, I tried compiling from TeXworks a one line file containing \RequirePackage{array}\stop and the results from TeXworks and the command line versions are identical. Both report

This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian) (format=pdflatex 2014.9.12)

and also have the line /usr/share/texlive/texmf-dist/tex/latex/tools/array.sty in them, so that shouldn't be an issue. Futhermore, the path indicated in that thread /usr/local/texlive/2013/bin/x86_64-linux is empty on my computer.

Please help. What can I do to get TeXworks to find these paths? For what it's worth, I tried installing Kile, which I am not familiar with, and it had the same problem.

Thanks.

Edit: I tried running kpsewhich on a .sty file that TeXworks couldn't find, and of course kpsewhich reported the correct location. I guess this isn't surprising since the command line latex versions work.

  • 1
    Hi and welcome to TeX.SX Do you have TeX Live 2013 or 14 installed? Look at the texworks preferences and look out for the foourth tab (Textsatz in german) -> There you can set the paths/places to search. – Johannes_B Sep 12 '14 at 20:06
  • I have TeX Live 2013/Debian, Version 3.1415926-2.5-1.40.14. I did try adding entries to the paths as you suggested, but this doesn't seem to have any effect. Those paths are for the commands that get called (i.e. pdflatex or bibtex), but don't seem to be for the related files (e.g. .sty or .bst files). TeXworks and the command line seem to be calling the same versions. – Max Sep 12 '14 at 20:26
  • If you don't want to put the bst etc. in your texmf-home, try setting a link from texmfhome to your Dropbox folder. But i have no idea if this is gonna work. It's just a pretty wild guess. – Johannes_B Sep 12 '14 at 20:30
  • 1
    How exactly are you starting texworks? Remember, if you start an editor from a menu, then any setting in bashrc is ignored. You need to add them to .profile, log out and log in again. If you start texworks from the command line it will know the setting from bashrc – daleif Sep 12 '14 at 21:29
  • @daleif: Yes! Thank you so much. That fixed it completely! I have no idea why (and at this point, it doesn't matter), but on my old computer I didn't have to add these to .profile: TeXworks saw the paths even launched from the menu. Oh well. Everything is working now. Thanks! – Max Sep 15 '14 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.